Joining the Community is Easy!

Our community is a great place to share and connect with other people that are passionate about the same things you are. Get your questions answered, share your ideas and feedback, get your problems solved, and give back by helping others! It only takes a minute to get started.

Get Started Today

  • Step 1: Sign Up
  • Step 2: Follow Categories

Conversations

Conversations 1 - 20 of 355
Photo of Philip Soltwedel
Blinking Yellow light
When attempting to start my mower it will start and run for about a second and then stops. The yellow indicator light blinks. Battery is ...
  • 2 me toos
  • 2 replies
  • Problem
Photo of Jennifer Lynn DiFiore
20" mower shuts down every 2-10 second.
I have a 2 year old 20" mower: it ran like a champ the past two years, however this spring it began to shut down every 2-10 seconds. I ha...
  • 2 me toos
  • 2 replies
  • Problem
  • In Progress
Photo of PK
battery or mower overheating
21" self propelled mower keeps shutting off after 5 to 10 minutes of use. Orange shining light indicates the battery or mower is overheat...
  • 4 me toos
  • 5 replies
  • Problem
  • In Progress
Photo of Artem
Wheel
Left rear wheel for mower bent. Need to find a replacement.
  • 2 me toos
  • 5 replies
  • Problem
  • In Progress
Photo of Jeramy Alexander
Not sure if I have a bad battery or a bad charger or niether
My battery for my lawn mower blinks green red and yellow all the time from the moment I took it out of the box. After a couple of uses an...
  • 2 me toos
  • 0 replies
  • Problem
Photo of Doug Stevens
ST1200 Trimmer collects grass under bump head which bogs the motor down.
ST1200 Trimmer collects grass under bump head which bogs the motor down and gets shaft very hot. This has been an ongoing and frustrati...
  • 1 me too
  • 2 replies
  • Problem
  • In Progress
Photo of Michael G
Hedge trimmer time delay to start (HT2400)
I used my hedge trimmer maybe 3 times last year and when I went to use it today I thought it was failed. Pushed the safety then the t...
  • 1 me too
  • 3 replies
  • Problem
  • Solved
Photo of Seth Andrews
LM2102SP power indicator
Power indicator does not function and never has. That is until the battery dies then it flashes red (thanks!). Any hope of correcting this?
  • 1 me too
  • 2 replies
  • Problem
  • In Progress
Photo of James Perry
Grass to tall
Have setting on 1.5. lowest setting.would like grass cut lower is this possible.
  • 1 me too
  • 2 replies
  • Problem
  • In Progress
Photo of jbonn
Issue with the self propelling power output
The power output when self propelling started to be inconsistent. In other words, the self propelling power goes up and down at any outpu...
  • 2 me toos
  • 2 replies
  • Problem
  • In Progress
Photo of Mark Cameron Boyd
Mower Bag Not Working
When mowing with my my 48V self-propelled it leaves “trails” of cut grass that the bag is not picking up; bag is filling ok but these tra...
  • 1 me too
  • 2 replies
  • Problem
  • In Progress
Photo of Chandran
BOLT TOO TIGHT WHEN CHANGING BLADE; BLADE NICKED EASILY WITHIN 6 USES;
BOLT TOO TIGHT WHEN CHANGING BLADE; BLADE NICKED EASILY WITHIN 6 USES; MULCHING NOT TOO GREAT AT SETTINGS BELOW 4; UNEVEN CUTTING REQUI...
  • 2 me toos
  • 4 replies
  • Problem
  • In Progress
Photo of tammy tanum
Front wheels won’t stay adjusted. Keep dropping down to lowest position no matter which height adjustment is used
  • 1 me too
  • 2 replies
  • Problem
  • In Progress
Photo of Michael
Power Head trimmer attachment stops spinning
Just recently the trimmer attachment for my Power Head developed a problem. When I hold down the trigger, the trimmer head will briefly ...
  • 1 me too
  • 5 replies
  • Problem
  • Solved
Photo of David Skuza
Handle Clip Pin Breakage on My Self-Propelled 21"
The clips that hold the handle in the extended position has pins inside that snap into holes in the metal handle. Otherwise, the handle s...
  • 2 me toos
  • 5 replies
  • Problem
  • Solved
Photo of dbull058
New chainsaw running through oil incredibly fast -- is this normal?
I recently bought an Ego 16" chainsaw and have used it twice. In both cases, it ran through bar oil far more quickly than I'd expected, a...
  • 1 me too
  • 5 replies
  • Problem
  • In Progress
Photo of Eric Stephenson
My 56v battery won’t charge. It just blinks and turns off. I see other posts with this same issue but I don’t see any answers.
My 56v battery won’t charge. It just blinks and turns off. I see other posts with this same issue but I don’t see any answers. Very frust...
  • 3 me toos
  • 1 reply
  • Problem
  • In Progress
Photo of eric
Laying grass down
I had a new 20 inch ego and it cut my grass perfectly level. I decided after only a month or so to upgrade and buy the 21 inch self prope...
  • 1 me too
  • 6 replies
  • Problem
  • In Progress
Photo of William Marsh
Hedge trimmer without battery pack
I recently purchased the EGO Power leaf blower with battery and charger with the idea that I would be able to purchase other EGO products...
  • 1 me too
  • 1 reply
  • Problem
  • Acknowledged
Photo of Ronnie Marshall
Hello Just used my new EGO ARC 56v ,power trimmer, Model ST1521S
I am not real happy with this Trimmer, The string cuts in a clockwise direction which throws all the grass toward the user. All other wee...
  • 2 me toos
  • 2 replies
  • Problem
  • Not a Problem