Yellow and red lights more frequent

  • 1
  • Problem
  • Updated 1 month ago
  • In Progress
  • (Edited)
On my 3rd year with the mower - and love it still.  (Since I got the High Lift Blade that is) However, it's getting more frequent the yellow or orange light (meaning, according to what I can find) means stressed or overloaded.

So I have to release the bail and wait til the lights go off, and start mowing again.  This seems to be happening more and more as if it is clogged.  I do mulch with the high lift blade FWTW.  I know it isn't the battery as I have a smaller one I can switch to and continue also.  Also not a dull blade as I put a new HL on about a week ago (keep one on the shelf they're that dang important)

I guess I will try to nurse it thru the summer (hopefully) and bite the bullet and send it in come fall when mowing is stopped for the winter.

If I can't nurse it thru, I guess I'll send it in for repair and buy another one.  Only way I can deal with the wait from what I've read about HD's horrible repair times.
Photo of bloomz

bloomz

  • 13,378 Points 10k badge 2x thumb

Posted 3 months ago

  • 1
Photo of Ann Pelfrey

Ann Pelfrey

  • 212 Points 100 badge 2x thumb
i can't believe the repair time! how would it take 4 weeks for a simple repair? does that mean we all bought an expensive piece of crap- recommended by Consumer Reports? i have used corded mowers that never bogged down.
Photo of bloomz

bloomz

  • 13,378 Points 10k badge 2x thumb
Ego sent me a new battery with few questions asked.
I do dread sending it in, but will possibly do this after mowing season this year.

I still love mine tho and don't consider it a POS at all.
Photo of Ann Pelfrey

Ann Pelfrey

  • 212 Points 100 badge 2x thumb
my battery seems fine. i feel that it has to do with one of the relays on the mower.
Photo of Tae Cooke

Tae Cooke

  • 1,602 Points 1k badge 2x thumb
A similar thread mentioned that cleaning the underside of the mower fixed their problems. Have you done so?
Photo of Ann Pelfrey

Ann Pelfrey

  • 212 Points 100 badge 2x thumb
i have cleared underside during mowing when i hear it "straining"- never have mowed wet grass. but is dense during spring. i could not be more careful about that issue. and i have had corded mowers that never bogged down!

Photo of Bernie Basel

Bernie Basel

  • 292 Points 250 badge 2x thumb
I'm having the same problem, with my third year on the mower.  After a while it looses power and the battery rapidly flashes yellow for a few seconds.  If I start it right back up it will do the same thing, if I wait  5 or so minutes everything appears to be normal.  I don't think it is the battery.  When I take out the battery it is not warm to the touch.  I scrape the underside of the deck after every use so that is not the problem.  I'm wondering if the motor is overheating?  Are there vents that I should be cleaning?
Photo of Ann Pelfrey

Ann Pelfrey

  • 212 Points 100 badge 2x thumb
my mower is also 3 years old. i actually looked for for vents , thinking they would be sensors to the battery. i cleared every tiny hole underneath. i am still waiting for a response from this company. i'm beyond disgusted.
Photo of szwoopp

szwoopp, Champion

  • 90,700 Points 50k badge 2x thumb
Waiting for a response ?
Did you call Ego CS ?
Did you leave a call back request ?
Has it been more than 48 hours ?
I would be proactive and call them and not wait (too long) for a response
Photo of Ann Pelfrey

Ann Pelfrey

  • 212 Points 100 badge 2x thumb
contacting on email.have sent photos of all the serial numbers and store receipt.
and recently have asked on the status. you are right!
Photo of Ann Pelfrey

Ann Pelfrey

  • 212 Points 100 badge 2x thumb
i called on phone- was told to take to Home Depot. took it today, and was told they send it elsewhere for service. 6 weeks! i think i should be given a "loaner". can not believe this crap!