Troubleshooting EGO 56V blower that does not start

  • 1
  • Question
  • Updated 3 months ago
  • In Progress
EGO 56V blower does not operate.  Battery has green light.  Charger has green light.  What thoughts on troubleshooting?
Photo of John Mordy

John Mordy

  • 70 Points

Posted 3 months ago

  • 1
Photo of Ken

Ken, Champion

  • 45,902 Points 20k badge 2x thumb
Which blower? Ego makes several.
Photo of Oregon Mike

Oregon Mike, Champion

  • 21,350 Points 20k badge 2x thumb
Is this a new blower? Is it one you've had awhile and worked before? If new, have you fully charged the battery? The batteries don't come fully charged from the factory. I know on my 575 blower there is a slight delay after pulling the trigger before the blower starts up. Maybe that is what you are experiencing? 
Photo of szwoopp

szwoopp, Champion

  • 48,116 Points 20k badge 2x thumb
Make sure the battery is fully seated in the blower and you hear the click.  Should have to press the locking tab in order to get the battery off of the blower.

Some more details of what you have tried as well as specifics on the blower model as Ken mentioned would all be helpful.
Photo of TheAtomTwister

TheAtomTwister

  • 12,762 Points 10k badge 2x thumb
The older 480 units have a long history of having problems.  Some of them quit in a way where when you put the battery on and pull the trigger, absolutely nothing happens, as if the circuit were completely broken somewhere (I'm guessing in the motor controller). 

It would be helpful to know exactly what happens when you try to activate the unit if anything, along with what the other guys here have said.