The blade will not turn to cut grass

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: CS

The first mower I bought today cut about 25-50 feet of grass in good conditions.  I stopped and came back and mower would not cut a single blade in spite of the fact that the battery was fully charged. I called EGO to which the rep walked me through starting the mower. Nothing worked, and he told me to go to a service center to which I responded, I would rather take it back to the store so that I can exchange it.  I exchanged it.  Then, I brought the second mower back and charged the new battery to the new mower.  With the battery fully charged, I started the mower and the blade did not turn.  I read online that it could be the green grips that are part of the safety and that is not it because everything is tight and in the needed position. I have a Home Depot employee taking time right now to help me and he will call me back in about 20 minutes.  I think I will take it back and wait until Tesla makes an e-mower.
Photo of Jill Johnson

Jill Johnson

  • 100 Points 100 badge 2x thumb
  • very angry and frustrated.

Posted 4 years ago

  • 1
Photo of Samuel Strong

Samuel Strong

  • 2,060 Points 2k badge 2x thumb
Official Response
Hello Jill,

Thank you very much for your post and we would like to apologize for the trouble you had. We will make sure we follow up with our support team to insure that this does not occur again. If you need any more help, please give us another chance. We promise we’ll try to do better.
(Edited)