String feeding too fast

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Duplicate

I have the 15 inch string trimmer and the string feeds way too fast.  I have tried restringing existing spools and yes if you wind it the wrong way it is even faster, but I have also used the pre strung spools that I bought and even those will not last me through one trim of my yard which is only 80 feet by 80 feet.  There is not thick brush...just standard grass and if I try to use my Ego, I go through 3 or 4 spools just on this small area...I have a secondary electric line trimmer and if I go through 1 small spool in the same area that is a lot.   If it is wound wrong I would probably go through 10 or more as it is gone in about 10 feet...but this is still a lot of string for such a small area.
Photo of Joan

Joan

  • 100 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of BigC

BigC

  • 1,134 Points 1k badge 2x thumb
I agree with you, I have the same issue, I wish ego would make a larger spool so I could put more string on it or fix this issue.
Photo of Blue Angel

Blue Angel, Champion

  • 179,968 Points 100k badge 2x thumb
Joan and BigC, there's something wrong with your trimmers! Some people, like me, can go through a whole season of trimming without having to add more string.

When you had the head apart to re-string, did you notice if the green button had a spring installed? I.E., if you push the button down does it spring back, or does it stay down or not push down at all? This could be the reason the line feeds out so fast.

Have a look. If the spring is missing you'll need to get a new one, if it's there and doing its job we need to investigate further. :-)
Photo of David Cline

David Cline

  • 37,182 Points 20k badge 2x thumb
Is it advancing even when you don't bump it? Or does it just advance too fast when you bump it?
Photo of BigC

BigC

  • 1,134 Points 1k badge 2x thumb
It advances to fast when bumping and the string does not last long at all???
Photo of Blue Angel

Blue Angel, Champion

  • 179,968 Points 100k badge 2x thumb
The included string is not the longest lasting... if you're trimming against rock or brick it can wear down quickly.

However, bumping the line should not advance the string more than an inch or so at a time. If it's feeding out much more than that it's not working properly.
Photo of Joan

Joan

  • 100 Points 100 badge 2x thumb
Same thing...seems to advance too fast...can not tell if it is advancing when not bumping.  Yes...just checked the spring and it is there an in tact.
Photo of David HD

David HD, Champion

  • 35,062 Points 20k badge 2x thumb
Joan, I definitely would call Customer Service about this.  I bought my 15" trimmer in early 2016 and used it regularly during my weekly yard work.  I am still using my original string which came with my original spool head.  I am now on year two and have yet to replace my string - so to Blue's point, something is not working correctly.  It should not advance the string that quickly ... :-)
Photo of BigC

BigC

  • 1,134 Points 1k badge 2x thumb
Do you have there contact number?
Photo of David HD

David HD, Champion

  • 35,062 Points 20k badge 2x thumb
Yes, see below.  Plus it is also available on the Home Page of this Forum as well ... :-)

Customer Service Department can be reached at 1-855-EGO-5656 (1-855-346-5656) from 8:30AM - 8:00PM EST (Monday - Friday) & 10:00AM - 6:00PM EST (Saturday & Sunday).
Photo of BigC

BigC

  • 1,134 Points 1k badge 2x thumb
Mine too?? I even bought some really good line and it does the samething :-(-/--<
(Edited)
Photo of Joan

Joan

  • 100 Points 100 badge 2x thumb
I have bought both prestrung spools and bought a spool a regular that lasts just fine in my other trimmer...why this one is going through it so fast has me baffled.
Photo of David HD

David HD, Champion

  • 35,062 Points 20k badge 2x thumb
I have a 15" trimmer, backpack blower, hedge trimmer, 575 CFM blower, and the new Power Head and Edger Attachment, and to date, the 15" trimmer is the BEST EGO tool for me, so I am baffled as well, as to why your trimmer is eating up the string so quickly ...
(Edited)
Photo of David Cline

David Cline

  • 37,182 Points 20k badge 2x thumb
Mine takes 2-3 bumps at pretty high throttle for the line to hit the blade... something is definitely amiss here.

The line it comes with is crap. Not sure if other twisted is any better.
Photo of David HD

David HD, Champion

  • 35,062 Points 20k badge 2x thumb
Mine only takes 1 good bump at high throttle, so I have been lucky I guess.  As to the "original" string, it is not the best quality but it has been doing a pretty good job for me - so I am not complaining.  That said; I did purchase a "higher" quality replacement string last year, but have not need it yet ... :-)
Photo of Blue Angel

Blue Angel, Champion

  • 179,968 Points 100k badge 2x thumb
Mine too, one bump at high speed feeds every time.
Photo of Hal

Hal

  • 320 Points 250 badge 2x thumb
Joan,

It sounds as if there is something wrong. Call customer service. I have an acre yard and I can trim the whole thing with 20 feet of line....Good luck
Photo of Jacob

Jacob

  • 65,000 Points 50k badge 2x thumb
Yeah. Some thing is terrible wrong with your bump feeder. Hopeful ego just sends ya a new bump feed head.
Photo of Amber F.

Amber F., Official EGO Rep

  • 68,272 Points 50k badge 2x thumb
Official Response
Joan, call our customer service team: 1-855-346-5656. Whatever it is that’s going on with your trimmer, they’ll be able to sort it out. 
Photo of Joan

Joan

  • 100 Points 100 badge 2x thumb
I have already called...and the only outcome was to take it to a Home depot service center...pay the 20 dollar evaluation fee and let them figure out the problem...so now my almost unused trimmer costing yet another 20 dollars

This conversation is no longer open for comments or replies.