Strange mower problem

  • 2
  • Problem
  • Updated 2 years ago
  • Solved
Merged

This conversation has been merged. Please reference the main conversation: Popping noise from battery?

I've had my mower for a couple of years and the only problem until now has been the latch/switch mechanisms on the handles popping open. Today, half way through mowing, I stopped and when I tried to restart, the battery and mower lights were green but the blade didn't spin. I checked all latches on the handle, recharged the battery, and let it cool down. It does the same. I could swear i heard a popping sound a couple of times like a fuse blowing. Any suggestions?
Photo of Kyle Towers

Kyle Towers

  • 92 Points 75 badge 2x thumb

Posted 3 years ago

  • 2
Photo of Jacob

Jacob

  • 64,144 Points 50k badge 2x thumb
Hmmm. Your going to want to call customer service. They will know what to do.
Photo of Jacob

Jacob

  • 64,144 Points 50k badge 2x thumb
If popping is what you heard, there is a capacitor on the motor control board that went bad on a scrap mower i got on ebay. I think they smell pretty bad when they pop also.
Photo of Samuel Strong

Samuel Strong

  • 2,060 Points 2k badge 2x thumb
Official Response
Hello Kyle,

Thank you for your post and we are sorry to hear your mower is no longer working. From what you have described, it seems that this issue may be a bit more than just the handle clamps. If you would please contact us at 1-855-346-5656, we can troubleshoot a bit further and help you with the warranty process. We look forward to hearing from you.
Photo of Linda

Linda

  • 92 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled Battery Made Loud Popping Sound when placed in charger.

After 2nd mowing, we put the battery in the charger and it made a loud POP sound.  Is this normal or defective?  Is it safe to use again???

This conversation is no longer open for comments or replies.