Snowblower won't stay running- Run time question

  • 2
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
Hello every one.  Brand new snowblower, batteries say 100%.  Runs for 5 seconds with no load and then shuts off with the indicator light blinking green/yellow.  Tried to call customer support (who are supposed to be open 7 days/week)  Message says they are in a staff meeting?  Really?  If you say you are there to answer questions, don't have a message saying "we are in a staff meeting call back next business day"...
Anyway, any suggestions that anyone has would be appreciated.  Frustrating to spend this much and not even have it run.  Thanks in advance
Photo of DMcMichael

DMcMichael

  • 210 Points 100 badge 2x thumb
  • frustrated

Posted 3 years ago

  • 2
Photo of William P Tucker

William P Tucker

  • 882 Points 500 badge 2x thumb
If you were running with the lights on, turn them off and see if it will now run. Either way, you will have to report the problem to EGO customer support.
Photo of DMcMichael

DMcMichael

  • 210 Points 100 badge 2x thumb
Thanks William.  I did try it with and without lights and it makes no difference.  
Photo of Erik

Erik

  • 10,800 Points 10k badge 2x thumb
If you looked right at the top of the community page it says they're closed today for updates.
(Edited)
Photo of DMcMichael

DMcMichael

  • 210 Points 100 badge 2x thumb
Ahhhh....thanks for pointing that out Erik.  Hoping they aren't closed tomorrow as well...patience...patience...
Photo of Blue Angel

Blue Angel, Champion

  • 180,078 Points 100k badge 2x thumb
Other than holiday weekends, this is the first time they've been closed on a regular business day in longer than I can remember... just bad timing! :-)
Photo of W. Bruce Cooper

W. Bruce Cooper

  • 504 Points 500 badge 2x thumb
This issue is like one that some of have hit in the past, likely related to a manufacturing defect.  Take a look at the issue "My brand new snow blower won't start" for comments.  You will need to return the snow blower and obtain a replacement.  I took my new snow blower to a local Home Deport for a credit and ordered a new one.  The replacement started, and I have used it for four snow storms thus far without incident. 
Photo of DMcMichael

DMcMichael

  • 210 Points 100 badge 2x thumb
Thanks for your reply, W. Bruce Cooper.  I was able to reach someone this morning and they were great.  A replacement is now processing and on it's way to me.  I would have returned it but, there are no more snowblowers in the whole state of Utah at any Home Depot!  I had to drive 1.5 hours just to get the one I have now.  Hoping we don't have issues with the new one being shipped.  Thanks to everyone for their help.
Photo of Vanessa Adams

Vanessa Adams

  • 72 Points
I can relate to this. We're also in Utah and had to order ours online because the local Home Depots didn't have any in stock. Had to wait two weeks for it to arrive; and now it won't start. Back to shoveling.
Photo of Ken

Ken, Champion

  • 73,600 Points 50k badge 2x thumb
Official Response
Vanessa, call Ego customer service tomorrow and they'll get a replacement to you right away.
Photo of Dudedigital

Dudedigital

  • 432 Points 250 badge 2x thumb
This reply was created from a merged topic originally titled Ego Snow Blower Run-Time.

I own all Ego products and just purchased an Ego snow blower. I used two 5.0 batteries. My neighbor and I started at the same time. I moved a little faster but as I was almost done with my driveway the red lights came on. Really, already? Only about 20 minutes in. Snow is 5-6 inch of lightly packed (semi wetish) snow. I alternated between slow speed and max speed. It threw it good and far. My driveway is your average 2 car size and just a little longer. By the time I started the sidewalk the red began flashing and I pulled it in and set it to charge immediately. Meanwhile my neighbor was still going. I'll admit, I had gas envy for a moment. Now I gotta wait 30 min just to finish the last little bit. Is two 5.0 enough? I couldn't image doing it with anything less. Should Ego have defaulted to two 7.5? I'm kind of happy I got it but disappointed at its run-time.

This conversation is no longer open for comments or replies.