Snow blower runs for only 8 seconds

  • 1
  • Problem
  • Updated 4 weeks ago
  • In Progress
Purchased snow blower in Nov-2017 it worked fine for 2-3 times then for no reason it just stopped working,  

I go to restart it runs for exactly 8 seconds as counted out, then shuts down.  New 7.5 batteries even in warm 70f inside does exactly same thing.  

Called and received a replacement in January 2018, and it snowed 2-3 inches of powder snow today, driveway 3/4 finished and once again it does exact same things, runs for 8 seconds then turns off with orange/green flashing lights.  

I brought snow blower inside to heater garage, inserted new freshly charged batteries, it starts, runs for 8 seconds as counted then shuts down, under no load what so ever.  Exact same results for 2 different units.  

First unit manaf. may-2017 replacement made sept/2017.

Needless to say now waiting on a third unit as a replacement.

Anyone have any idea's, not only was this a costly purchase, as I purchased every EGO power tool in order to get 4 batteries and 4 chargers, but now very frustrating as I could have purchased a 2 or 3 stage blower for around the same price.
Photo of tim harvey

tim harvey

  • 172 Points 100 badge 2x thumb

Posted 4 weeks ago

  • 1
Photo of Amber F.

Amber F., Official EGO Rep

  • 45,356 Points 20k badge 2x thumb
Official Response
We're so sorry you had such a frustrating experience, Tim. Please know that this is not normal and in no way reflective of how our snow blowers are designed to perform. You have our sincere apologies, but we think you're going to love the new unit! If you have a moment, please circle back and let us know how you like it. Hopefully the third time is the charm!