Short run time on mower

  • 13
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Duplicate

My mower only runs a short time before the unit shuts off. Talked with customer service. They asked me to charge the battery fully, and then to check and record the run time. They also asked me to charge the battery, and run it in my string trimmer and record the time. The results were... 4 minutes and 15 seconds run time in the mower. (At that point, the yellow light came on, and the mower would not run.) After recharging the battery (Which took only a few minutes), I used the string trimmer to edge my yard. That took a little over 23 minutes. The battery showed no sign of problems. Customer service told me to take the mower, battery, and charger to Home Depot for repair. I was less than impressed with the product knowledge of the man I spoke with at HD, but time will tell what service they give me.

Some info... Mower and battery are about 10-months old. Grass was dry. Yard had been mowed 6-days prior to the failure. Blade spins freely. Very small yard (Less than 1/4 acre). Bermuda grass. Sharp blade. No accumulation of grass around blade.

I'll be borrowing my neighbor's mower for a month or more. He has an E-GO which I had recommended to him. (I'll be wearing my humble hat when I go tell him of my problem). Will post any info I receive, so others who encounter a similar problem can read the results.
Photo of George Lammers

George Lammers

  • 232 Points 100 badge 2x thumb

Posted 4 years ago

  • 13
Photo of Denise C

Denise C

  • 6,334 Points 5k badge 2x thumb
Official Response
Hi George! Thank you for sharing your experience with the EGO community. Please keep us posted on your repair, and do not hesitate to give us a call if you have any additional questions in the meantime.