Self Propelled Speed control failed. I now only have one speed ... slow. Any one else experience this?

  • 1
  • Question
  • Updated 1 year ago
  • In Progress
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Duplicate

The speed control on my EGO 21" Self Propelled mower became intermittent (defaulting to the slow speed) and then it stopped altogether. I now only have one speed ... slow. Any one else experience this?
Photo of MGCoady

MGCoady

  • 100 Points 100 badge 2x thumb
  • disappointed

Posted 1 year ago

  • 1
Photo of Blue Angel

Blue Angel, Champion

  • 158,214 Points 100k badge 2x thumb
There have been a couple of similar reports. As of now there doesn't appear to be a user fix.

Give Ego Customer Service a call, tomorrow AM if on hold for long, and they'll discuss your options. There was a report of long wait times today.
Photo of MGCoady

MGCoady

  • 100 Points 100 badge 2x thumb
Thanks! I've called Customer Service and left a message (you were correct ... a long wait). They said they would call me back within 24 hours on a business day.

Does Ego have local service centers?

Mike
Photo of Jacob

Jacob, Champion

  • 61,356 Points 50k badge 2x thumb
Sounds like a bad potentiometer. But yeah. Ego will need to fix you up.

If you have had it less than 90days, I'd exchange it if I was you. Or 1 year if bought with a home Depot credit card.
Photo of Blue Angel

Blue Angel, Champion

  • 158,214 Points 100k badge 2x thumb
Ego service is done through the Home Depot. If your local HD doesn't do repairs on site the mower is sent to a repair facility.

This conversation is no longer open for comments or replies.