Self-propelled mower moves but does not mow

  • 1
  • Problem
  • Updated 3 months ago
  • In Progress
Bought a new LM2102SP self-propelled mower. I powered up the battery to full charge. After installing battery, I can get the mower to propel about the yard, but the mower function does not start up. I’m depressing all of the handles, but get nothing. This is very disappointing.
Photo of Wayne

Wayne

  • 72 Points
  • frustrated

Posted 3 months ago

  • 1
Photo of duane

duane

  • 280 Points 250 badge 2x thumb
Push the button then pull back the bar
Photo of William E Hanson

William E Hanson

  • 19,416 Points 10k badge 2x thumb
The sequence is important to engage the mower; it's a safety feature to prevent accidental starts. As duane said, push green button in and hold while pulling the bale back to start. Once started, you release the green button. Also for the self propel release shortly before you want it to stop, turn and engage the self propel again. May seem awkward st first, but you'll get used to it quickly.
Photo of mike

mike

  • 316 Points 250 badge 2x thumb
Mine was doing the same thing. See if it comes on when u raise the handle like in this video https://youtu.be/pWYtoDaYCB0
Photo of William E Hanson

William E Hanson

  • 19,416 Points 10k badge 2x thumb
Mike, what was done to fix your problem?
Photo of mike

mike

  • 316 Points 250 badge 2x thumb
Just got my 2102sp back from ego repair shop couldn’t believe when I go to start it thinking all is well and should be good as new but no it’s doing the same damn thing when I brought it in 2 months ago. Called customer service told them the issue and they’re shipping me a new mower. So that’s cool. Just saw the email with the tracking earlier today. They're also sending me the rma for the old mower to ship in the new box. Of course
(Edited)
Photo of szwoopp

szwoopp, Champion

  • 104,032 Points 100k badge 2x thumb
Good to hear they took care of you Mike.  Thanks for the update.