Self propelled feature stuck in turtle mode

  • 1
  • Problem
  • Updated 2 months ago
  • In Progress
I move the throttle into rabbit mode, but it stays going the slowest speed. Does anybody have an idea of what is wrong? It's under warranty, but read horror stories. I am good at fixing stuff, but where do you buy replacement parts?
Photo of Doug Dinger

Doug Dinger

  • 348 Points 250 badge 2x thumb

Posted 3 months ago

  • 1
Photo of szwoopp

szwoopp, Champion

  • 104,286 Points 100k badge 2x thumb
Official Response
You can try Ego CS for a possible source for the needed part.
Photo of William E Hanson

William E Hanson

  • 19,416 Points 10k badge 2x thumb
RCPW.COM

If you make the repairs, EGO may void your warranty, so be sure to ask beforehand.
Photo of Doug Dinger

Doug Dinger

  • 348 Points 250 badge 2x thumb
I am used to voiding warranties.
Photo of William E Hanson

William E Hanson

  • 19,416 Points 10k badge 2x thumb
Doug, sounds like you should offer EGO repair services; bet many would be willing to use you over the typical lengthy wait through approved channels.
Photo of Doug Dinger

Doug Dinger

  • 348 Points 250 badge 2x thumb
Decided I'm going to call ego after all. It's under warranty, and can't get parts easily.
Photo of William E Hanson

William E Hanson

  • 19,416 Points 10k badge 2x thumb
Doug, call first thing in the morning to avoid long waits.
Photo of Doug Dinger

Doug Dinger

  • 348 Points 250 badge 2x thumb
Thanks. Will do
Photo of Shannon Pitcher

Shannon Pitcher

  • 60 Points
Did they send you a part?
Photo of Doug Dinger

Doug Dinger

  • 348 Points 250 badge 2x thumb
No. I had to take it to Home Depot. They shipped it to Ego, and I was told this past Monday that it's on it's way back to the store.