self-propel doesn't work

  • 3
  • Problem
  • Updated 3 years ago
  • Acknowledged
Merged

This conversation has been merged. Please reference the main conversation: Self-propel not working

Mower blade is working but the self-propel feature doesn't work. I depress the lever and can adjust the speed control but nothing happens.
Photo of Eric Stemm

Eric Stemm

  • 146 Points 100 badge 2x thumb

Posted 3 years ago

  • 3
Photo of Julio Villanueva

Julio Villanueva

  • 1,860 Points 1k badge 2x thumb
Has it ever worked before? I'm planning on buying this specific model and I'd really appreciate to read all possible issues with this mower. Pros and Cond
Photo of Eric Stemm

Eric Stemm

  • 146 Points 100 badge 2x thumb
Just bought it today and didn't work. Tried contacting customer support but they are in a staff meeting according to the recorded message.
Photo of Julio Villanueva

Julio Villanueva

  • 1,860 Points 1k badge 2x thumb
if you live close to a Home Depot store (I assume you bought it there) I would take it and exchange it. Why take the risk that you got a lemon
Photo of David Cline

David Cline

  • 36,932 Points 20k badge 2x thumb
I would talk to Ego first and make sure that there isn't just some safety mechanism or possibly even a user error before going through all the hassle of boxing it back up and exchanging it.

It sounds crazy, but there have been plenty of reports around here of people having the exact same problem with a second mower after exchanging it (some even more than one exchange) before finally realizing it was something they were doing wrong.
Photo of Eric Stemm

Eric Stemm

  • 146 Points 100 badge 2x thumb
I stowed the handles back and then started the procedure from the beginning and the wheels finally engaged. However at the same speed setting, it would jerk going from full speed to slow. Then after releasing the handle it would sometimes engage again and sometimes not. I wound up just taking it back to Home Depot and exchanged it for the non-propelled version.
Photo of SCDC

SCDC, Champion

  • 53,748 Points 50k badge 2x thumb
Speaking from Experience.  I love the non-propelled EGO mowers.  They are the standard in light, easy to handle mowers.
Photo of David Cline

David Cline

  • 36,932 Points 20k badge 2x thumb
That's very odd—I haven't heard any other reports of an issue like that on this site or in any of the 168 Home Depot reviews. You must have found a rare defective mower because that definitely isn't how the self propel should work and no one else has had that issue.

It's a shame you gave up the 7.5Ah battery in the exchange—that battery is a technological marvel that sells for over $300, and is a real steal to get with the self propelled mower for only $100 more than the non-propelled model.
Photo of David Cline

David Cline

  • 36,932 Points 20k badge 2x thumb
That's interesting to have a staff meeting on a Saturday—I would think that's their busiest day for customer support calls, plus most corporate staff are probably off on weekends. Unusual timing. Anyway, the message says you can leave your contact info and someone will return your call by tomorrow. I would definitely do that since they'll probably be even more busy than usual the rest of the day once they return.

As far as the self-propel issue, has it worked previously and then stopped working? Does anything happen at all when you pull the green self-propel lever?
(Edited)

This conversation is no longer open for comments or replies.