Question about charger fan and mower condition

  • 1
  • Question
  • Updated 5 years ago
  • Answered
I just received my mower and trimmer from home depot online yesterday. Not happy about the fact that they did little to no taping on the package. I expected them to ship it in the retial box but the top flap was open on one end and the trimmer box wasn't even reinforced (could easily just open it like in the store). I haven't tested the trimmer yet but did open the mower and had a few questions.

When I charged the battery the first time, the fan would not stop as the manual stated once it charged. I waited a couple of minutes but maybe it takes longer? However when I put the battery back on the charger this morning after testing the mower, the fan didn't come on so maybe that was a fluke last night?

Also, I don't think the mower was a return (the top was still glued on half of the side) but did anyone notice dust/dirt on the bottom black plastic on the sides, scratches, etc on the mower when they opened it the first time? I assume it's from the egg crate stuff that the mower sits in. I'm not OCD at all and do expect there to be marks, etc with it being a mower and the nature of manufacturing (and the fact that it will get that way the moment I start mowing) but was surprised to see this. I guess also seeing the top flap half unglued made me think of it being a return. The box was really beat up from UPS (trimmer box looked okay and wasn't as bad) so maybe that's why.

Anyway, thanks for the help!
Photo of YOTR

YOTR

  • 90 Points 75 badge 2x thumb

Posted 5 years ago

  • 1
Photo of SCDC

SCDC, Champion

  • 54,538 Points 50k badge 2x thumb
Official Response

Hi Justin,

The fan will stay one for however long the built in thermal sensor determines that the battery temperature is within the programmed limits.  These are very advanced battery packs.  What you describe is normal.  When you put the battery in the second time, it was cool enough for the fan to stay in the off position.

Now about the mower, when I unpacked mine, it was packaged well.  I think you may have gotten a return without all of the packaging.  I also had no dust that I can remember.

As this isn't a problem caused by EGO, I would return it to Home Depot for an exchange, but if you are content that it hasn't really been used and are fine with it possibly being a return, then keep it and remember that you have a 5 year warranty on the mower and 3 years on the battery.  Not much risk.

Thank you.