Proper replacement blade

  • 1
  • Question
  • Updated 1 month ago
I have Model# LM2100 Serial #NLM03160205524 Feb. 2016. I recently replaced my blade and ordered from you. The old blade was #CH3705938001, new blade is #CH3706059001. The problem I am having orange light is blinking and mower is not starting, sometime. There is no pattern. It may start ten times in succession then not start 3 times or more. I purchased a second mower, 9/9/2018, Model#LM2100SP, Serial#NLM04171105492X Nov. 2017. It has CH3705938001. I have switched batteries from mower to mower and have no problem with the new mower and same problem with the old mower. I am a TOOL Tech. with Home Depot and have been for the past 5 years. I push your product heavily but am a lost on this problem.  
Photo of David M. Murphy

David M. Murphy

  • 220 Points 100 badge 2x thumb

Posted 1 month ago

  • 1
Photo of Ken

Ken, Champion

  • 49,834 Points 20k badge 2x thumb
Have you tried switching the blades to see whether that's the problem?
Photo of Clay Cassell

Clay Cassell

  • 166 Points 100 badge 2x thumb
Am I missing something? I don't think your blade has anything to do with your problem. Think it may be more electrical related. Maybe a switch?
Photo of Paul Christenson

Paul Christenson

  • 5,022 Points 5k badge 2x thumb
There was a weight difference in the regular blade and the mulching blade that caused mowers to fail to start
(Edited)
Photo of szwoopp

szwoopp, Champion

  • 63,008 Points 50k badge 2x thumb
There is a standard blade (all purpose designed for mulching and/or bagging.  These come with the mowers.

Ego also makes a High lift blade which is designed for extra lift and thus bagging. These are sold separately.

I am not aware of either Ego blade causing problems with Ego mowers when properly installed.
(Edited)
Photo of Paul Christenson

Paul Christenson

  • 5,022 Points 5k badge 2x thumb
What happened to the posting about the guy who had to drill his blade in an attempt to lighten it??
Photo of Oregon Mike

Oregon Mike, Champion

  • 32,580 Points 20k badge 2x thumb
Paul, EGO doesn't make a mulching blade. They have the standard blade suggested to use for mowing and mulching and they also have a high lift blade which is for helping in bagging clippings.
Probably not a good idea to be modifying the blades.
Photo of Paul Christenson

Paul Christenson

  • 5,022 Points 5k badge 2x thumb
Okay...maybe it was a high lift blade that had to be drilled because it was too heavy...either way...that thread seems to have disappeared
Photo of David M. Murphy

David M. Murphy

  • 220 Points 100 badge 2x thumb
Believe it or not, after talking with customer service at Ego I found the problem. After replacing my old blade with hi-lift blade, I had over tightened. Simply backing off a quarter turn on blade holding bolt a 1/4 turn, problem solved.
Photo of szwoopp

szwoopp, Champion

  • 63,008 Points 50k badge 2x thumb
Customer service comes thru again.  Thanks for the follow up David.  Glad to hear you got things worked out.  Happy mowing.
Photo of Oregon Mike

Oregon Mike, Champion

  • 32,580 Points 20k badge 2x thumb
Great to hear this, David.