Problem with my Power Blower

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
My blower now only works on Turbo mode. It barely blows at all in the normal speed. What should I do?
Photo of Bill Tipper

Bill Tipper

  • 70 Points

Posted 4 years ago

  • 1
Photo of Billy Roehr

Billy Roehr

  • 192 Points 100 badge 2x thumb
Does it sound like the the motor is still running with out the turbo button pressed?
Photo of Blue Angel

Blue Angel, Champion

  • 179,988 Points 100k badge 2x thumb
Official Response
Bill, it sounds like you might need some troubleshooting help from Ego on that one. Give Customer Service a call at 1-855-EGO-5656 (1-855-346-5656) 8:30-8:00 M-F 10:00-6:00 S/S.

If they're not available by phone send them an email at:

support@egopowerplus.com

Include your contact information, a description of the issue you're having, and make sure your tools and accessories are all registered:

http://egopowerplus.com/pages/registe...

Someone from the Customer Service team will get back to you ASAP, help troubleshoot your problem and get you the help you need.

As long as you bought your tools from a registered dealer, they are covered by Ego's 5 year tool and 3 year battery warranty:

http://egopowerplus.com/pages/warrant...
Photo of TheAtomTwister

TheAtomTwister

  • 13,128 Points 10k badge 2x thumb
You should go ahead and remember the location of this post or something so you can be ready to copy and paste its content where appropriate, cause it's pretty thorough. I wish I'd thought of this before :D
Photo of Jacob

Jacob

  • 65,000 Points 50k badge 2x thumb
Blue has that as a hotkey lol