Power indicator light on battery pack won't stop flashing green.

  • 16
  • Question
  • Updated 2 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Duplicate

Greetings,

After extensive research of online reviews, yesterday evening I took the plunge and purchased a new EGO power string trimmer model ST1500SF. After first time use of 25-30 minutes of light trimming I noticed the power indicator light on the battery pack was flashing green continuously. I put the battery back on the charger. The battery pack has been on the charger for over 8 hours and the power indicator won't stop flashing. Is this normal?

Thanks,
Tony
Photo of Anthony Biondi

Anthony Biondi

  • 380 Points 250 badge 2x thumb

Posted 3 years ago

  • 16
Photo of Egocentric

Egocentric

  • 6,328 Points 5k badge 2x thumb
No it is not normal.  There have been several other complaints regarding the same issue.  I think the prescribed solution is to call customer service and they will send you a new battery.  However if you bought the trimmer at Home Depot you should be able to return it for another unit.  Note that Ego's customer service will be closed on Memorial Day.   Sorry your new trimmer has this issue.  Its an awesome trimmer otherwise, and the new battery will fix you right up.  
Photo of Anthony Biondi

Anthony Biondi

  • 380 Points 250 badge 2x thumb
Thanks for the prompt reply and concise advice.  I'm going to Home Depot now to run an errand now and will discuss with them for how they wish handle the situation.  Hopefully they will take care of it by simply swapping a battery. 
Photo of Egocentric

Egocentric

  • 6,328 Points 5k badge 2x thumb
Be careful and make sure you get the same battery.  The ST1500SF comes with a 2.5 aH battery...if they want to trade it with a 5.0  magnificent, but watch that they don't give you a 2.0.  

Let us know what happens with that, I am curious.  It would make sense to just exchange batteries, but with computerized stock and so forth it might be cheaper for them to just exchange the whole unit.  If they do exchange just the battery, be sure to register the new serial number with Ego.  Good luck!
(Edited)
Photo of Anthony Biondi

Anthony Biondi

  • 380 Points 250 badge 2x thumb
Thank you for your thoughtful tip.  I was at Home Depot today (05/28/17) and explained my situation.  It was my hope Home Depot would crack open the box of new unit and just swap out the battery.  The sales associate recommended, as you suggested, to exchange the entire unit with a new one... to which I easily complied. 

By the way, the Home Depot in my area only stock 2.0 aH battery which sells for $129.00 while the entire unit (trimmer, charger and battery) sells for $149.00.

Thanks for the reminder of registering the replacement unit.  Done!    
Photo of Egocentric

Egocentric

  • 6,328 Points 5k badge 2x thumb
Glad it all worked out for you.  Better luck with this trimmer and I hope you like it.  
Photo of Anthony Biondi

Anthony Biondi

  • 380 Points 250 badge 2x thumb
Thanks!  The real test will come when I do the yard next week.  I want it to go well because the trimmer itself is awesome.  I will revert with an update next week. 
Photo of Anthony Biondi

Anthony Biondi

  • 380 Points 250 badge 2x thumb
Update - Good news! Tried the replacement trimmer today with the new battery.  This time... no constant flashing green indicator light on the battery pack and also got much longer run time.  Everything appears normal.  The first battery (the defective one) gave me about 25 to 30 minutes of run time which wasn't enough to trim my entire yard. By contrast, the new battery had sufficient capacity to trim the entire yard in about 40 minutes of light trimming with more juice to spare in battery pack according to the power indicator light. I hope that trouble free operation will persist for many months to come.
Photo of Egocentric

Egocentric

  • 6,328 Points 5k badge 2x thumb
Anthony, thanks for the update.  I am glad the replacement got you fixed up and it worked out good for you.  Good luck with the new unit.  
Photo of Natalie Serge

Natalie Serge

  • 72 Points
Anyone know what causes the battery to start flashing? What does it mean?
Photo of Blue Angel

Blue Angel, Champion

  • 179,948 Points 100k badge 2x thumb
It's a defect in the battery circuitry. If this happens give Ego Customer Service a call and they'll get you fixed up.
Photo of Natalie Serge

Natalie Serge

  • 72 Points
My battery isn't under warranty, since I bought it on ebay. But other than the flashing green light, it seems to work just fine.
Photo of Anthony Biondi

Anthony Biondi

  • 82 Points 75 badge 2x thumb
It's the the 6th or 7th time I use the trimmer since replacing the defective battery which barely gave 30 minutes of trimming time.  I give the trimmer a pretty good workout when I use it.  It takes 45 to 50 minutes to trim the grass around flower, beds, trees, driveway, etc.  I also use the trimmer as a edger by rotating it 180 degree such that the string is perpendicular to the ground to cut a clean well defined edge around of flower beds, shrub beds and driveway.  I haven't yet managed to get power indicator to flash red.  Truly impressed!  
Photo of jeff Blair

jeff Blair

  • 92 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled 56v battery after charging and removing battery from charger green power indicato....

Power indicator flashing green
Photo of NatoriousFAT

NatoriousFAT

  • 72 Points
I'm having this problem a second time with the ST1502SF. I've already had to exchange the entire unit once this summer. I'm still within the 90-day Home Depot return policy, but if the same thing will continue to happen, I'm not sure it's worth the trouble of trying again.
Photo of NatoriousFAT

NatoriousFAT

  • 72 Points
I ended up just returning mine to Home Depot for a refund before my return window closed. I didn't want to be stuck trying to get replacement batteries every time this happened.
Photo of Michael G

Michael G

  • 8,810 Points 5k badge 2x thumb
Oh boy, my ST1502SF light started flashing green today. Called CS and a new battery is on its way. Ironically my sons trimmer battery did the same thing two days ago! Both were bought this year and batteries only charged once.
Photo of MNL

MNL

  • 62 Points
After reading above comments, I'm not going to deal with the hassle of getting my battery replaced.  Going to return it to home depot.
Photo of Dwayne Williams

Dwayne Williams

  • 110 Points 100 badge 2x thumb
Same problem here with a pair of 2.5 Ah batteries.  Both were used in the ST1502 trimmer as well.  So is the issue with the batteries or is the trimmer somehow ruining the batteries?  
Photo of Jeff Newton

Jeff Newton

  • 174 Points 100 badge 2x thumb
When I called customer service I was told that it was a bad battery. It seemed to me that they had dealt with this problem some already. I had registered my equipment on line so she was able to look it all up and got me a replacement battery sent out right away. No fuss, no hassle just good service. I have had no problems with the replacement battery as to this date and have had no problems with the battery that came on the blower that I bought at the same time. Give customer service a chance to help. I hope you have the same experience that I did!
Photo of (a)Typical Engineer

(a)Typical Engineer

  • 26,632 Points 20k badge 2x thumb
Appreciate the positive feedback report.
Photo of Randy Freed

Randy Freed

  • 122 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled 5.0 amp battery flashing green.

After using my trimmer today the battery started flashing green and won't stop. Putting it on the charger does nothing.
Photo of Tri Lai

Tri Lai

  • 118 Points 100 badge 2x thumb
I bought a blower two weeks ago and the battery has the same problem. The battery died after two uses.  I called the Customer Service on Monday (4 days ago!), left a message and never got their response. They said that they will call me back in 24 hours. I am so disappointed!
(Edited)
Photo of szwoopp

szwoopp, Champion

  • 105,650 Points 100k badge 2x thumb
As it has only been 2 weeks you can just take it back to HD for an exchange.  Bring the whole kit you purchased tool, battery, and charger.  Then they can just replace it with a new one.
Photo of Tri Lai

Tri Lai

  • 118 Points 100 badge 2x thumb
Yes, I am definitely going to Home Depot. However, I would ask for a refund since I am so upset with the product quality AND the customer service quality. I have called them,  waited for more than 1 hour, and finally left a message 4 days ago. Still not get them call back though.

Since they said they will call back within 24 business hours, I am wondering if they only work for 5 hours a day or they got too many calls complaining about defected products. 
Photo of Jacob

Jacob

  • 65,000 Points 50k badge 2x thumb
Since your so upset about it, exchange it or return it. That's what I would do.
Photo of szwoopp

szwoopp, Champion

  • 105,650 Points 100k badge 2x thumb
Customer service issues is a question mark.  Many people have posted about great customer service. Unfortunately there have been some posts like yours where people have had trouble getting thru. Not sure what the issue is.
The blowers are well rated and well liked by those using them, so you may want to give it another chance.  Quality problems with the blowers have not been an issue I have read about.  
(Edited)
Photo of Tri Lai

Tri Lai

  • 118 Points 100 badge 2x thumb
@szwoopp. In my point of view, the battery should be considered as a part of the electric blower here. The blower cannot run without the battery right. Moreover, the battery is made by EGO and designed specifically for EGO product.  Therefore, if the battery is bad, then I cannot say that the blower is good here.  This is similar to the case of a laptop or a MacBook, if the battery is bad, then no one says that it is a good MacBook or laptop.

We should only distinguish the quality of the machine and that of the battery if we can use batteries of other brands for the machine, such as in the case of cars and trucks.
Photo of szwoopp

szwoopp, Champion

  • 105,650 Points 100k badge 2x thumb
Agree completely.  My point is I think you may have gotten a bad one and in general the tools (batteries included) are very good quality.
My suggestion is to give the Ego blower another shot and see if you don't enjoy using the replacement.  If not then return it for a refund.
You got to do what makes you happy, so I certainly understand if you decide to move on, personally I go the route of everyone (companies I work with included) generally deserves a second chance.
Photo of Tri Lai

Tri Lai

  • 118 Points 100 badge 2x thumb
@szwoopp. I did call them and ask for a replacement. I did not want to go back Home Depot though.

However, what can I do if they did not answer my calls, and did not call me back either? I should update that the customer service has not called me back (after 5 days from the first call), and I tried to call them one more time (for more than 30 minutes) and still got no answer.
Photo of szwoopp

szwoopp, Champion

  • 105,650 Points 100k badge 2x thumb
Agree there have been reports of some trouble getting hold of CS and sorry to hear you are one of them.  If heading back to HD is a hassle for you then that make the CS non response a real issue. I have a HD within 10 minutes of my house and 5 minutes of my office, so that is an easy solution for me (not the case for everyone).

Have you tried calling CS first thing in the morning (I know you shouldn't have to, they should call back as promised). but many have reported getting right thru early in the day before the CS cue backs up.

In any case, hopefully Jen or Amber will see this and someone will be contacting you on Monday if you do not get things worked out today.

Good luck - I hope things turn around for you on this issue.
Photo of Tri Lai

Tri Lai

  • 118 Points 100 badge 2x thumb
Done! I returned the blower. I don't want more trouble and don't have much time for calling and waiting for a response from CS. I hope that EGO would improve its customer services and the quality of the batteries. 
Photo of Jacob

Jacob

  • 65,000 Points 50k badge 2x thumb
So it's not a hassle to return it, but exchange it is? ...... .... ...

I guess good luck.
(Edited)
Photo of szwoopp

szwoopp, Champion

  • 105,650 Points 100k badge 2x thumb
Battery quality is great and the reason I invested in this line of tools.
Unfortunate you got a bad one or that something happened to it while you had it.  Also unfortunate you had a bad CS experience.
But I have had nothing but good results and the batteries have a 3 year warranty, so I am still still confident in the products.
Photo of Roger Topping

Roger Topping

  • 290 Points 250 badge 2x thumb
I was on hold for more that 50 minutes and then pressed 0 to leave call back but then sent to another line with same message and then after ten minutes was able to press 0 and ask for callback. We''l see. Hope they boost their CS department. Heck Sunjoe responded better that these folks.
Photo of Roger Topping

Roger Topping

  • 290 Points 250 badge 2x thumb
CS called me back next morning and sent them my receipt. Then no response so I called back. Got a live person who put in order for new battery. Seems they have some CS issues they are working on. Also, problem may be caused by charging battery and then letting it sit at full charge. They said it's better to 1/3 to 1/2 charge it an then store it. Charge it fully just before use. Hopefully, they will better disseminate this information and add a charge indicator to battery so we consumers can follow this procedure more easily and have optimal battery life.
Photo of Blue Angel

Blue Angel, Champion

  • 179,948 Points 100k badge 2x thumb
Roger, see my reply to your other post. Ego’s long term storage mode is built into the battery and happens automatically.
Photo of Roger Topping

Roger Topping

  • 290 Points 250 badge 2x thumb
Also got replies form other Ego reps to do partial charge for long term storage as described above. In another thread, a user actually tested battery degradation using both methods and active method or partially charging did better than depending on built in storage mode. Still don't know what the fault is that caused blinking light. 

This conversation is no longer open for comments or replies.