Power Head trimmer attachment stops spinning

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
Just recently the trimmer attachment for my Power Head developed a problem.

When I hold down the trigger, the trimmer head will briefly spin as normal, however after 5-10 seconds, it makes an awful "grinding" noise, like it can't spin anymore.

I take out the battery and I manually spin the trimmer head with my hands, and there is a lot of resistance as it spins. But after about 5-10 seconds of manually spinning the head, the resistance magically goes away and I can manually spin it without issus.

However, after I put a battery back in and hold the trigger, it will only spin normally for 5-10 seconds until it make the grinding noise again, and I have to manually spin it again to get the resistance to go away.

I've tried multiple batteries, so it's not the battery. The guard is attached, so that shouldn't be the issue.

I purchased the item in October 2017.

Any advice?
Photo of Michael


  • 120 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Oregon Mike

Oregon Mike, Champion

  • 83,354 Points 50k badge 2x thumb
Official Response
When it makes that noise and stops, have you tried separating the trimmer attachment from the power head and just turn the trimmer head to see if the binding is still there? Trying to determine if it's the trimmer head attachment or the power head part. Have you tried disassembling the trimmer head assembly, based on the instructions in the manual, to see if you can see if anything is broken or binding up? (Assuming it's the trimmer head that's the problem)
The good part is it's still under warranty so you can call EGO CS. Call early in the day to avoid hold times.
They can be reached at 1-855-EGO-5656 (1-855-346-5656) from 8:30AM - 8:00PM EST (Monday - Friday) & 10:00AM - 6:00PM EST (Saturday & Sunday).
Photo of Ken

Ken, Champion

  • 73,680 Points 50k badge 2x thumb
This is kind of an outside chance, but the trimmer attachment has a port for adding grease for its transmission. You might also check to see if that needs to have grease added to it.
Photo of Blue Angel

Blue Angel, Champion

  • 180,360 Points 100k badge 2x thumb
In addition to what’s been said, make sure the attachment is inserted all the way into the Powerhead; there’s a line on a sticker indicating how far it needs to be inserted before tightening the screw. You should hear the button click and you should not be able to remove the attachment without pressing the button. Only once it’s in all the way should you tighten the screw.
Photo of Michael


  • 120 Points 100 badge 2x thumb

I did as you all requested.

I disassembled the trimmer head attachment and made sure nothing appeared wrong.

I then used a plastic syringe with a curved tip to insert a good amount of Lucas Oil "White Lithium Grease" into the transmission grease port on the the trimmer head. (Home Depot & Lowes sell a large tube of the stuff for less than $5, and Amazon has the syringes for about $1 per syringe)

I then unwound the spool and rewound the line into the trimmer head as shown in the instruction book.

Everything is now working as it should. I'm not sure exactly which one of the steps had fixed the issue, but I would lean toward the grease being low in the transmission. When I unscrewed the port, I could not see anything in there (though I am no mechanic, so who knows).

Thanks for everything. You can mark this problem as SOLVED.
Photo of Oregon Mike

Oregon Mike, Champion

  • 83,354 Points 50k badge 2x thumb
Michael, thanks for circling back on this. I bet it was the grease. Nice to "hear" all is working well again.