No Speed Control

  • 1
  • Problem
  • Updated 1 month ago
  • Solved
Always was curious about these mowers, been a gas guy all my life. Found a Lm2100SP someone was selling. Did some research and a lot of pro reviews, but some cons also. I like to catch my grass, I have a lot of shade so fungicide is a concern. The original equipment blade had a lot of complaints with vacuum issues. But Ego did design what they call a High Lift Blade, and it was awesome. They say this blade is only design for catching grass, not mulching. While testing the mower before buying it never enter my mind to test the speed control. So when I took it home for the first time and started mowing, I couldn’t keep up with the mower. The mower Speed was stuck in the fast position, making difficult to pick up leaves
Photo of Howard Hoffman

Howard Hoffman

  • 822 Points 500 badge 2x thumb
  • Displeased with the manufacturer not knowing this issue.

Posted 3 months ago

  • 1
Photo of szwoopp

szwoopp, Champion

  • 42,924 Points 20k badge 2x thumb
Official Response
Howard
If you are a do it yourself type, give Ego CS a call and see if they can help you trouble shoot and perhaps sell you the part you need after helping you identify it.  Or you can try here

https://www.rcpw.com/ego-parts/

they have a lot of parts available.  If neither of those work you will need to take it in to a autorized repair center.  CS will also be able to direct you to one near you if that is your only option or if you are not a do it yourself type.

1-855-EGO-5656 (1-855-346-5656) from 8:30AM - 8:00PM EST (Monday - Friday) & 10:00AM - 6:00PM EST (Saturday & Sunday).