Newby frustrated with line feed.

  • 2
  • Problem
  • Updated 2 months ago
  • In Progress
I had a great time using your 15" String trimmer that I bought Yesterday from Home Depot until today. I am reloading the line I bought from Home Depot and was told by the Clerk, "I don't see anywhere on the package that this won't work with your product so I will say yes this is the correct line and then I am going to run away." Di not give me much confidence in Home Depots product knowledge. The line I am using is Blue in Color. Brand name Speed Pro .095. Heavy Duty Professional Line. I have loaded 16" of LIne as well as about 6 feet of line and the results are the same. Sometimes the feed stops with only one side of the spindle showing line. Sometimes their is no line exposed at all. Suggestions?

Photo of Kevin Rivard

Kevin Rivard

  • 110 Points 100 badge 2x thumb
  • Frustrated, and ignorant even after following the instructions.

Posted 3 months ago

  • 2
Photo of William E Hanson

William E Hanson

  • 19,356 Points 10k badge 2x thumb
Kevin, the 16' of .095 line is to be pulled through so that equal length is left on both sides before turning the Hub to wind into the spool leaving about 16" exposed and the blade will trim then line on use.
Photo of Kevin Rivard

Kevin Rivard

  • 110 Points 100 badge 2x thumb
Thank you William. I have been doing that. I may have found my problem. I just completed cutting down two to three foot weed growth on the side of my house. Had no problem with the line. When I was having problems it was using the trimmer as an edger so to speak and I believe I was probably breaking the line on the cement. So when I saw one line still exposed I assumed the line that was not exposed was not advancing. When both lines were missing even though I had lots of line left in the spindle I probably had broke off both lines and that is why they were not advancing. Once my battery is charged again I will experiment more. This is the best trimmer except for the learning curve. Thank you again for responding. 
Photo of dwayne rattan

dwayne rattan

  • 202 Points 100 badge 2x thumb
Hi sounds like you got some crap line from home depot. But i see you already figured that out. Try the vortex line its good quality