New battery defective.

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: out of date

Bought a EGO lawn mower today. Got it home and put battery on mower and it worked for about 3 seconds. Put the battery on charger and got a code telling me the battery is defective. Not happy as the only Home Depot that had one in stock was a 90 minute drive one way.
Photo of John

John

  • 70 Points

Posted 4 years ago

  • 1
Photo of David Cline

David Cline

  • 37,182 Points 20k badge 2x thumb
Ego support will be available tomorrow. Register your new mower kit (and battery) and then give them a call. If you include your number they may even call you before you can call them.

They should be able to confirm that the issue is the battery and ship a replacement to you that will arrive within a few days.
Photo of Denise C

Denise C

  • 6,334 Points 5k badge 2x thumb
Official Response
Hi John! Thank you for your post, and we are sorry to hear that you are having issues with your mower and battery. I see that you called in yesterday and that Rebekah did additional troubleshooting with you, and she determined it was the battery. An order was placed for a replacement battery today, and please just give us a call at 855-346-5656, or send us an email to support@egopowerplus.com once it arrives with the new battery's serial number so we can update it for you; and to also let us know it is working for you with the new battery.

This conversation is no longer open for comments or replies.