My snowblower wont turn on

  • 4
  • Problem
  • Updated 1 year ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

Tried to start the snowblower today and it just started for a split second and went dead. I had used this 4 times earlier . The battery is fully charged.
Photo of Jomi

Jomi

  • 126 Points 100 badge 2x thumb
  • frustrated

Posted 3 years ago

  • 4
Photo of Darrell Birck

Darrell Birck

  • 156 Points 100 badge 2x thumb
I had the same issue about 1 hr ago...had only used mine 1 time before...I check the front and everything was clear and it would rotate freely.  I have a second set of batteries for other EGO items I purchased but nothing.  It's dead.  I thought I could smell something burnt.

I am returning to Home Depot after shoveling my sidewalk and driveway
Photo of Jacob

Jacob

  • 65,000 Points 50k badge 2x thumb
It's dead and your not alone. This seems like a widespread issue. Sadly
Photo of Deleted

Deleted

  • 4,108 Points 4k badge 2x thumb
Any chance that the blowers are sucking in water through the rear intake fins causing to motor to drop too much in temp and shut off? Anyone try bringing the snow blower inside to warmer temps to see if it will start up? I brought mine in for an hour or so after it stopped working, kicked up again. I 100% agree it's unacceptable that a snow blower cannot handle the cold but at least we could find out what might be causing them to stop working instead of just complaining....
Photo of Jacob

Jacob

  • 65,000 Points 50k badge 2x thumb
The inside is covered with snow. Well mine is. I'm heating it up to see if this will help fix it
Photo of Deleted

Deleted

  • 4,108 Points 4k badge 2x thumb
I'm really surprised the boards aren't epoxy potted, big mistake from ego!
Photo of Jacob

Jacob

  • 65,000 Points 50k badge 2x thumb
They are coated. In a clear layer of something. You can see it if you zoom in. It's noticeable because portions are yellow
Photo of Troutboy

Troutboy

  • 930 Points 500 badge 2x thumb
Wow. Snow INSIdE the housing, sounds like poor design...... water/moisture is the enemy for electric based systems.......
Photo of Deleted

Deleted

  • 4,108 Points 4k badge 2x thumb
Must of used conformal coating instead of epoxy potting. Guess it works, but I feel the potting would provide more temperature resistance... again im thinking a lot of these units are being submerged in icy slush causing a low temp sensor to kick on and shut the unit off.... no bueno!
Photo of Deleted

Deleted

  • 4,108 Points 4k badge 2x thumb
Moisture inside isn't going to affect anything if the boards and connectors are coated, it's basically waterproof... but ice water on an electric motor or sensor board...theressss your sign....
Photo of Jomi

Jomi

  • 126 Points 100 badge 2x thumb
If thats the design then there is no piint exchanging it..i am from chicago and today the temp iwas -4f when i tried to start the blower. ..
If it cannot handle the cold and the winter then there is no point keeping it. Planning to return.
Photo of Jacob

Jacob

  • 65,000 Points 50k badge 2x thumb
This is not confirmed. Let EGO respond before you make any decisions. It was -27 here today and I know of someone who used theirs today without any problems
Photo of Deleted

Deleted

  • 4,108 Points 4k badge 2x thumb
Maybe there's a firmware update for the blowers? Where's the USB port on these thinga majigs...
(Edited)
Photo of TheAtomTwister

TheAtomTwister

  • 13,128 Points 10k badge 2x thumb
Not another one...  If it is a design flaw, I'd switch to Snow Joe for now.

Spark, it sounds like you're a Bill Engvall fan.
Photo of TheAtomTwister

TheAtomTwister

  • 13,128 Points 10k badge 2x thumb
Not another one...  If it is a design flaw, I'd switch to Snow Joe for now.

Spark, it sounds like you're a Bill Engvall fan.
Photo of Jacob

Jacob

  • 65,000 Points 50k badge 2x thumb
TAT. This is an EGO forum. Keep that in mind when you suggest for others to switch to a competitor. We don't want EGO shutting this down. Plus the snow Joe ones seem like crap to me.
Photo of TheAtomTwister

TheAtomTwister

  • 13,128 Points 10k badge 2x thumb
I'm well aware of the fact that this is an EGO forum, and if the Snow Joe is crap, don't buy it. All I want is for people to get a snowblower that works and keeps working, and if EGO doesn't have it, then give me a reason to get it from EGO. I'm sorry, I like EGO quite a bit, and so do many of the people on this forum, but I'm fair minded and honest, and I will not hold myself back just because I'm here. If you get the same e-mail feed that I do, then you have seen one post after another after another about the snowblower having problems, and that gets me a bit concerned for people who buy it.
Photo of Deleted

Deleted

  • 4,108 Points 4k badge 2x thumb
Lol saying you should try snow Joe on an ego forum is like me repetitively saying i keep my gas non branded snow blower on hand due to these reliability issues. If ego deletes or blocks a thread, that would show a lack off faith in their own product. They're better off working on whatever minor issue is causing this and prove all the neigh Sayers wrong.
Photo of TheAtomTwister

TheAtomTwister

  • 13,128 Points 10k badge 2x thumb
Besides, EGO uses this forum to see what we the customers have to say about their products, and when people like you and I start saying that the snowblower has problems and start coming up with backup plans or whatever preparing for the EGO snowblower to fail, EGO will know very quickly that there is a problem, and so far this forum has given EGO the advantage of knowing peoples' responses in detail to their products better than companies without such a forum. Additionally, sometimes people on this forum can help EGO engineers find problems with the products and solve them, giving EGO an edge that no other company to my knowledge has. It would be EGO's disadvantage to do anything to interfere with this forum.
Photo of Jacob

Jacob

  • 65,000 Points 50k badge 2x thumb
I guess. I just worry about this forum being shut down if those types of suggestions happen often enough. I agree that we need to be brutally honest to keep EGO in check.
Photo of Jacob

Jacob

  • 65,000 Points 50k badge 2x thumb
TaT, Of course I've gotten all 120 emails today. Been a busy day.
Photo of TheAtomTwister

TheAtomTwister

  • 13,128 Points 10k badge 2x thumb
I understand on both counts. My thought is that if I were to hold back, I'd be defeating the point of being on the forum and its one of its purposes for existing. I know you understand all of what I'm saying and I understand your worry, but EGO gets probably similar forum feed to their e-mails as do I, you, Blue Angel, SCDC and many others. They'd probably understand people's responses to the snowblower... well, I see that we as engineers have a project: improving this snowblower so there won't be any more posts about EGO snowblower problems.
Photo of Jomi

Jomi

  • 126 Points 100 badge 2x thumb
I tried to see if it will start again today. But it did not.. if there was already a defective batch or recall needed, why did they not take all the defective ones off the shelf? The hassel of putting everything back in the box and taking back to the store is really tough, and it would be worse to think that there are defective products still out there in shelves.
Do the units that people exchanged already go back to EGO?or does it get back to shelf?
Photo of Jacob

Jacob

  • 65,000 Points 50k badge 2x thumb
Jomi. There hasn't been a recall. This is a brand new product. We are the first ones to see this issue
Photo of Deleted

Deleted

  • 4,108 Points 4k badge 2x thumb
Also don't worry about the origami packaging just bring it all together to HD if that's what you end up doing they could care less if it's packaged up nicely or not. Just don't forget the receipt!
Photo of J McFadden

J McFadden

  • 140 Points 100 badge 2x thumb
I had a similar issue and contacted EGO Customer Service. They asked to describe the issue I was having and asked me to check if the auger would rotate freely. After checking it and finding that it was frozen they indicared that mine was defective Upon sending an email with a picture of my sales receipt they confirmed that I was within the 5 year warranty period (just over 1 year old) and that they'd send me a replacement unit via UPS within 5-10 business days. less the batteries and charger (I can use the existing ones).
They then asked for the serial numbers on my existing snowblower , batteries and charger and my name, address and contact information in order to register the unit and then asked that I call back once the new unit has arrived to record the new serial number. They indicated that my existing defective unit be recycled and wouldn't need to be returned to them.
The whole process took less than 20 minutes. This was the most pleasant and professional experience I have ever had with a defective product and would definitely recommend EGO products to family and friends.
(Edited)
Photo of szwoopp

szwoopp, Champion

  • 106,122 Points 100k badge 2x thumb
Thanks for posting J.  It is always good to hear a good experience and instills confidence in continuing to invest in this platform.
Photo of Ajish Madhavan

Ajish Madhavan

  • 60 Points
I had the exact sameexperience. Stopped working. Called them, they asked me to email the sales receipt and then sent me a new one. Didnt take the old one back. Amazing customer service experience. Only bad part is, I have the non working one occupying space in the garage. Not sure what to do with it> Dont want to pay to get it recycled.
Photo of Paul Christenson

Paul Christenson

  • 7,618 Points 5k badge 2x thumb
Well, if your local school system has a tech program...you could donate it your school's electronic repair program

Otherwise...you could salvage the drive belt, the rear scraper and the paddles as replacement parts for your new snow blower
Photo of Blue Angel

Blue Angel, Champion

  • 179,988 Points 100k badge 2x thumb
Home Depot is not going to put a defective product back on the shelf. If you tell them the reason you're returning it is because it's not working, I'm pretty sure it goes back to Ego and HD gets a credit.
Photo of TheAtomTwister

TheAtomTwister

  • 13,128 Points 10k badge 2x thumb
That's what's supposed to happen, and I'd be surprised if customers keep something like "It doesn't work!" to themselves.

This conversation is no longer open for comments or replies.