My mower was working fine, emptied the bag, and wouldn't start, yellow intermitant light on mower.

  • 1
  • Problem
  • Updated 2 months ago
  • Solved
My mower has been working great for 96 days.  I cut most of my yard and emptied the bag.  When I tried to restart, the mower wouldn't run.  The lights and self-propel work, but no mower blade.  The light on the battery is green, the light on the mower blinks yellow every 10-12 seconds.  I put the mower away for several hours, same issue. 
Photo of Richard Ross

Richard Ross

  • 250 Points 250 badge 2x thumb

Posted 2 months ago

  • 1
Photo of walt dutchak

walt dutchak

  • 1,116 Points 1k badge 2x thumb
Page 21 of the owner's manual indicates the following:
- When the power indicator light is flashing orange then that means - "The mower stops due to overload."
- The action to take is: "Remove the battery pack, check and clean if grass has collected beneath the deck. Slow down your pace when cutting."
(Edited)
Photo of Richard Ross

Richard Ross

  • 250 Points 250 badge 2x thumb

The light is more yellow, and it only blinks occasionally until I pull the battery.  I cut often, so I'm not cutting much, and I'm not as young as I used to be, so I don't move fast.  I did fold it up and put it away for a while, then came back and tried again with no success.  The blade area is clean, and the blade turns freely by hand.  This only happened after I stopped to empty the bag, and tried to go back.  I did put the high lift blade on before starting.  There is a thought that the bolt could be over tightened, but, it doesn't even try to turn when I push the button and pull the bar.


Thank you for your help.  I'm very new to cordless tools, and don't quite know the ins and outs.
Photo of szwoopp

szwoopp, Champion

  • 69,188 Points 50k badge 2x thumb
Official Response
Check this list



Make sure blade is installed with the This side facing grass inscription facing down.  Bolt should be tightened at 38-43 lbs with a torque wrench.

If none of this works, then

Call customer service.  call early in the day to minimize any hold time.
1-855-EGO-5656 (1-855-346-5656) from 8:30AM - 8:00PM EST (Monday - Friday) & 10:00AM - 6:00PM EST (Saturday & Sunday).
Photo of Richard Ross

Richard Ross

  • 250 Points 250 badge 2x thumb
This reply was created from a merged topic originally titled lawn mower stopped working yellow light on mower blinks.

Mower has been cutting fine.  Emptied the bag, and it wouldn't restart.  The head lights work and the self  propel works.  A yellow light on the mower flashes every 10 to 12 seconds.  I waited hours and retried it, but, it is the same thing.  No mower, yellow light.
Photo of Richard Ross

Richard Ross

  • 250 Points 250 badge 2x thumb

I just got a calibrated torque wrench from work.  I will check the torque tonight and hope for the best.  I tried everything else in the manual.  My worst thought is a bad sensor somewhere.  Here's hoping for a torque issue.  Thank you all for your help.  If this works, I will post for information.

Thanks again!
Photo of Richard Ross

Richard Ross

  • 250 Points 250 badge 2x thumb

Well, I put the torque wrench on, and I was a couple pounds shy of 38 ft./lbs.  I tried to run it again before calling customer service.  Customer service was helpful beyond belief.  You just don't find helpful so much any more.  Talking to Home Depot was very disappointing, but EGO was great.  The issue seems to be something out of the norm.  A new mower is on the way, and I will have to send the old one back.  A little inconvenient, but, I really do like the mower, so much I bought the blower too.  Both actually perform as good or better than the gas powered tools I had.  Thank you all for the help.
Photo of Blue Angel

Blue Angel, Champion

  • 164,780 Points 100k badge 2x thumb
Good to hear, Richard! Thanks for the update!
Photo of szwoopp

szwoopp, Champion

  • 69,188 Points 50k badge 2x thumb
Thanks for letting us know how things worked out for you Richard.  Ego CS does do a great job