My LM2100 will not start. The battery charger indicates full charge.

  • 4
  • Problem
  • Updated 3 months ago
  • In Progress
My LM2100 will not start. The battery charger indicates full charge. The head lights come on but no mowing. I verified handle position is locked and is fully extended. Called customer service and was asked to leave my cell number for follow up when they were available. No call back.
Photo of Steve MacDonough

Steve MacDonough

  • 100 Points 100 badge 2x thumb
  • unhappy and disappointed with customer service

Posted 3 months ago

  • 4
Photo of Greg Wethey

Greg Wethey

  • 62 Points
I have the same model with what appears to be the same issue. I was in the middle of mowing my lawn when the blade simply slowed then stopped. Battery is at or near full charge. Self propel feature is fully functional, lights works, etc. This is extremely disappointing. I had to return my original purchase due to a self propel feature failure. I’n May 2019 I had planned to return the replacement with the same issue until it “magically” began to work again. Now, 4 months later no mowing capability.
Photo of michelle walker

michelle walker

  • 182 Points 100 badge 2x thumb
If you have another EGO product try the battery in that to see if it’s a battery issue. If not, you have to speak with someone from customer service. Not sure why you didn’t get a call back, I would try them right when they open. They will troubleshoot over the phone to determine if it’s the charger, the battery, or the mower.