My leaf blower suddenly stopped working while blowing leaves today.

  • 2
  • Problem
  • Updated 3 years ago
  • Solved
My blower quit working suddenly today while clearing leaves. I didn't register it when I bought it last year and I don't have the original card I purchased the blower with from Home Depot. EGO customer service wouldn't do anything for me without a receipt (which I can't get). It is still under warranty though. Help!
Photo of Travis Gregory

Travis Gregory

  • 90 Points 75 badge 2x thumb
  • Frustrated

Posted 3 years ago

  • 2
Photo of David Cline

David Cline

  • 37,182 Points 20k badge 2x thumb
I would go to the Home Depot location where you bought it and explain the situation to the store manager. Odds are they can still pull up your transaction and reprint a receipt copy, but it's probably not something they would normally do if it is even possible. I would go at a time they aren't as busy (avoid around 7a and 10a-2p) and be as nice as possible when asking.

If Home Depot can't help you, you might try calling the card issuer to see if they can locate a record of your transaction even though you don't still have the card.

A reciept is required for the warranty (and Ego will retain a copy for you if sent with registration as required). Getting a copy of that receipt is almost certainly the only way you are going to get your blower repaired or replaced under warranty.
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 81,048 Points 50k badge 2x thumb
Official Response
Hi Travis, we're sorry to hear about your blower. I've sent this along to our customer service team who are aware of this issue. Please give us a call one more time at 1-855-346-5656 (mention your name) and we can see what we can do to help you out with this issue.
Photo of Big Johnson

Big Johnson

  • 60 Points
I am currently waiting for my 3rd replacement to be shipped. The original lasted 1 week shy of 2 years. Thank God I had regustered it! The replacement lasted 3 hours!! Back on the phone again. The 2nd replacement arrived yesterday. It worked for 15 minutes this morning, gave a fairly loud scree vCard h, and died. Wonder if the 3rd replacement will make it past 10 minutes?
Photo of Blue Angel

Blue Angel, Champion

  • 180,008 Points 100k badge 2x thumb
Wow! I'm not sure I've heard anyone having worse luck with an Ego tool than that!

At this point I've gotta wonder if there's some outside influence like the battery or something?!?
Photo of Travis Gregory

Travis Gregory

  • 90 Points 75 badge 2x thumb
Luckily this is my first replacement and customer support was able to work with me since I didn't have my receipt. Hopefully the replacement holds up longer than yours have. Good luck!
(Edited)