my EGO mower started shutting down for no apparent reason (even with a full battery).

  • 2
  • Problem
  • Updated 6 months ago
  • In Progress
Hello, my EGO mower started shutting down for no apparent reason (even with a full battery). Sometimes it would shut down completely, sometimes it will only go backwards but not forward. It sometimes restarts for a second or two of I wait a while, but now does not start at all. There is no obvious obstruction and I can turn the blade manually both ways equally easily. Any idea what could be wrong?
Photo of Kocho X.

Kocho X.

  • 80 Points 75 badge 2x thumb

Posted 7 months ago

  • 2
Photo of Oregon Mike

Oregon Mike, Champion

  • 69,574 Points 50k badge 2x thumb
Official Response
Hey Kocho, sorry you are experiencing this. It sounds like one of the handlebar clamps isn't engaging the safety interlock in the handlebar. You might try opening the clamps, tugging up on the handlebar very firmly and reseating the clamps. 
Note that if you bought your mower at HD within the last 90 days (1 year if using an HD cc) you can return/exchange it no problem. If you are passed the return window the mower has a 5 year warranty so give EGO CS a call. They will help you out. Best to call early in the day to avoid hold times.
Photo of Bob

Bob

  • 150 Points 100 badge 2x thumb
These people are as frustrating as the DMV or some old Microsoft platform Incorrect answers change every time you finally get ahold of them. The staff evidently receive a bonus for every bit of warranty work they can delay or avoid by sending you on another wild goose chase. Their product idea is sound, it’s their execution that is severely lacking! Looking for another company now sadly. I have 2 years and 11 months of warranty left and have been trying to get this resolved for over five months.
Photo of Ken

Ken, Champion

  • 73,500 Points 50k badge 2x thumb
What exactly are you trying to get resolved?
Photo of Sibyl Smith

Sibyl Smith

  • 6,786 Points 5k badge 2x thumb
Does the orange light flash on the battery indicator?   If so, check to be sure you have the fan blade facing up and the flat side down.

My mower would not start and I got an orange flashing light when I cleaned the mower deck and reinstalled a newly sharpened blade - but I put the white fan blade in upside down.   There is no indicator which side is up on that part.   When I reversed the fan blade, the mower started right up!