My blower stopped working.

  • 7
  • Problem
  • Updated 4 years ago
  • Solved
Merged

This conversation has been merged. Please reference the main conversation: EGO Blower unexpectedly stopped working

My blower stopped working. Not the battery. Just nothing happens when pressing the trigger. Returned it to Home Depot and they said it was the 3rd blower returned with the same issue. A real bummer. A great product with a trigger glitch. What is the word on this issue?
Photo of rommy

rommy

  • 162 Points 100 badge 2x thumb

Posted 5 years ago

  • 7
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 81,048 Points 50k badge 2x thumb
Rommy, we're sorry to hear about your blower.  We're sorry to hear that we didn't get a chance to make this right for you.  While we are looking into this trigger issue, we do stand behind our products with our 5 year warranty.  We do strive for perfection but if we fall short, our customer service team is here to help.  We hope you'll give us another try in the future.
Photo of Earl Scanlon

Earl Scanlon

  • 70 Points
I am also having a problem with trigger it delays then finally will turn on it is still working other then this problem I will return when weather here gets better
Photo of Blue Angel

Blue Angel, Champion

  • 179,968 Points 100k badge 2x thumb
Earl, there is a soft start feature on the blower, it takes a couple seconds to ramp up to full speed. This is intentional and part of the brushless motor drive.

Is this perhaps the delay you are experiencing?
Photo of Earl Scanlon

Earl Scanlon

  • 70 Points
Okay because it does start ok thank you
Photo of Daochay

Daochay

  • 112 Points 100 badge 2x thumb
the blower DOES NOT start immediately, it DOES takes a few seconds to get going.  very normal.
Photo of SCDC

SCDC, Champion

  • 54,608 Points 50k badge 2x thumb
One thing people need to consider.  Electric motors can have a LOT of torque.  If the unit power up to full speed immediately, it could be a safety hazard.  Could jerk itself out of your hand.  Also, it would eventually cause the plastic to fail due to the stress.  Slow starting, high torque motors is the only way they can produce these tools and make them safe and reliable.
Photo of TheAtomTwister

TheAtomTwister

  • 13,128 Points 10k badge 2x thumb
Particularly with the kind of fans that those blowers use. I know that the Toro Ultra Blower Vac goes up to full power almost immediately, and yes, you do feel that jerk, but that blower is built to take that. The EGO isn't a blower/shredder or vacuum. It's just a blower. I do plan on doing a few experiments with the blower and posting videos of those experiments on YouTube in the hopes that I can find ways to upgrade the blower's power and a few other aspects of it. I imagine that I will come up with some pretty helpful information for EGO, though its engineers probably also experiment with the blowers. Still, an unofficial extra engineer can make a difference, as I intend to try to.
Photo of John Scavullo

John Scavullo

  • 70 Points
I appreciate that the company is replacing the blowers after they stop working. This will be the 3rd time this has happened to me. What is EGO doing to resolve the issue from reoccurring? 
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 81,048 Points 50k badge 2x thumb
John, we appreciate your concern.  While we strive for perfection, sometimes we fall short.  We are continuously improving our next generations of tools to avoid this kind of issue in the future.  We hope that knowing you have a 5 year warranty on the tool helps alleviate any concern you may have for the life span of your blower.
(Edited)
Photo of SCDC

SCDC, Champion

  • 54,608 Points 50k badge 2x thumb
I have to chime in an give a thumbs up to EGO.  I've seen no less than 3 improvements in the mower over the past 2 years.  Mainly functional improvement.  The only thing they had to fix over the year is the little locking clamps on the handle.  Point being, when you see a comment like this from Jennifer, it's factual.  I've learned this from monitoring the forums and helping people over the past year and a half, with some long timers like Blue, Jacob and David. 

These forums have been very valuable to many of us.  How many manufacturers look after their customers like EGO.  I don't know of any, and that's not coming from a fanboy point of view.
Photo of TheAtomTwister

TheAtomTwister

  • 13,128 Points 10k badge 2x thumb
What I'm curious about is how this is impacting EGO. I'm really going to try to figure out what is going on here. I should have the new blower on 10/12 or 10/13 if it ships in on schedule.  I'm going to see if I can get to the bottom of this this time. I know that it isn't the motor because I removed the motor from the first unit and the motor is fine. There just isn't any current.  I'm willing to take any non-functional blowers and see what's wrong with them by the way, if anyone is up for that. Send them either to me or to EGO. If you want to send one to me, e-mail me at theatomtwister@gmail.com. I will get back to you ASAP, and I will post my work on the blower on YouTube and send you the video link either by e-mail or in the EGO community or both.
Photo of Doug

Doug

  • 74 Points
Hi, I have recently encountered the same issue. The battery is perfectly fine.. . It's not that it starts slow ; it just doesn't start at all. Do I need to start a new conversation to get help with this issue?
Photo of Blue Angel

Blue Angel, Champion

  • 179,968 Points 100k badge 2x thumb
Doug, make sure your tools are registered and then give Ego an email describing your issue:

support@egopowerplus.com

Include your contact information and they'll get back to you ASAP.
Photo of Doug

Doug

  • 74 Points
Thank you so much for pointing me in the right direction!!
Photo of Blue Angel

Blue Angel, Champion

  • 179,968 Points 100k badge 2x thumb
My pleasure!

This conversation is no longer open for comments or replies.