My battery won’t release on my string trimmer. The release latch isn’t working.

  • 1
  • Problem
  • Updated 5 months ago
  • Solved
I can’t release the battery from my string trimmer. I have an ego blower and have never had this problem. The latch won’t release battery
Photo of Pati Walton

Pati Walton

  • 140 Points 100 badge 2x thumb
  • bummed

Posted 5 months ago

  • 1
Photo of Blue Angel

Blue Angel, Champion

  • 161,020 Points 100k badge 2x thumb
Official Response
Hi Pati,

Have you tried pushing the battery in while pressing the latch?  There's a spring loaded finger that holds the battery in place against the latch, if you can compress that finger slightly while activating the latch it may come out.  Just a thought if you haven't already tried it.

Also, have a look under the latch button to make sure there's no debris trapped in there that would keep the latch from moving through its proper range of motion.

If nothing works and the battery seems stuck for good, you'll have to give Ego Customer Service a call.  They can help troubleshoot the issue and get you whatever assistance you need.  If you do call them, try calling early in the day to avoid long wait times.
(Edited)