my 56V battery is flashing red and yellow and won't charge.

  • 2
  • Problem
  • Updated 4 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: customer service

I have a fairly new mower, just used a handful of times since I bought it last fall. The battery wouldn't charge when I got it out to mow. It flashes red and yellow. Is the issue the battery or the charger? What are my options?
Photo of Royal Tyler

Royal Tyler

  • 100 Points 100 badge 2x thumb

Posted 4 years ago

  • 2
Photo of Rob

Rob

  • 9,072 Points 5k badge 2x thumb
You're going to have to call customer service so they can try to diagnose the problem.  It could be one or both causing your problem. 
Photo of Royal Tyler

Royal Tyler

  • 100 Points 100 badge 2x thumb
I trued and tried. Couldn't get thru today. I was hoping this way I could reach someone.
Photo of Rob

Rob

  • 9,072 Points 5k badge 2x thumb

Were you given the option to leave a message?  I'm afraid anyone you get on here is going to just tell you to contact customer service.

Good Luck with this though.

Photo of Royal Tyler

Royal Tyler

  • 100 Points 100 badge 2x thumb
No. The computerized operator said no one was available. I guess I'll just have to keep trying again later in the week. First clear days we have had in forever and no mower.
Photo of Rob

Rob

  • 9,072 Points 5k badge 2x thumb
Wow, that bites.
Photo of Rob

Rob

  • 9,072 Points 5k badge 2x thumb

Here's their email


support@egopowerplus.com 

Photo of Blue Angel

Blue Angel, Champion

  • 179,708 Points 100k badge 2x thumb
Official Response
Royal, Ego just posted an announcement on the home page stating they're having trouble with their phones.  Send them an email as Rob suggested.

https://community.egopowerplus.com/ego/topics/technical-difficulties-with-phone
Photo of Blue Angel

Blue Angel, Champion

  • 179,708 Points 100k badge 2x thumb
Photo of Denise C

Denise C

  • 6,334 Points 5k badge 2x thumb
Official Response
Hi Royal! We want to apologize for the technical difficulties we were experiencing at the beginning of the week regarding our phone lines. I do see that you called in on Wednesday and spoke with Susan, and that during your call you were able to get the battery and charger working properly. If you have any further concerns or issues with these, or any other EGO product, please do not hesitate to contact us. 
(Edited)

This conversation is no longer open for comments or replies.