My 4.0Ah battery won't take a charge!

  • 1
  • Problem
  • Updated 6 months ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

My 4.0Ah battery won't take a charge! I have 2 other batteries that work fine on 2 seperate chargers. When I put this battery on the charger it doesn't kick on the fan and the battery light flashes red in a weird pattern
Photo of Dave Johnson

Dave Johnson

  • 70 Points

Posted 6 months ago

  • 1
Photo of Jacob

Jacob, Champion

  • 61,946 Points 50k badge 2x thumb
Official Response
Sounds like a dead battery to me. Chances are it is undercharged. It would need to be connected to another battery to bring the voltage high enough to initiate a charge.

Check the voltage of the battery by using a multi meter on the + and - terminals

If voltage is present and below 48v the follow the suggestion below at your own risk.

BE CAREFUL BECAUSE THIS IS NOT SAFE NOR RECOMMENDED. I WOULD DO THIS BECAUSE I TINKER WITH EGO STUFF ALL OF THE TIME.

Warning following the below suggestion is at your own risk. Ego is not responsible for anything my crazy fingers type.

go get 2 fuses and a switch the fuses should have wires on the ends. See below

Connect the fuses to male flat spade terminals

Connect one fuse and one switch inline with eachother

The other fuse will just be male spade terminals on both ends

Turn off the switch

Connect the negatives together with the fuse and spade

Connect the positives together using the one with a switch

Turn on the switch

If you wired it wrong then the fuses will pop

If not then the voltage at the bad battery will rise

Leave it there for a minute

Then quickly turn off the switch

Remove the jumpers

Slap that battery in the charger and hope it starts

Fuse


Spade terminals