my 21 inch 56 v self propelled mower has zero power.

  • 1
  • Problem
  • Updated 2 months ago
  • In Progress
I was mowing my lawn and it just shut off. I took the battery out and put on the charger. a few hours later tried starting it up and got nothing. adjusted the bars, tried pushing the lights button, no light, no self propel. nothing. any ideas as to what the problem is.
Photo of Spike Albertson

Spike Albertson

  • 70 Points

Posted 2 months ago

  • 1
Photo of Oregon Mike

Oregon Mike, Champion

  • 67,856 Points 50k badge 2x thumb
Official Response
Do you have another battery you can try in the mower? Any EGO battery will work in any EGO tool so don't worry if it's a different Ah battery. It's just to figure out if it's battery or mower.
Speaking of that, you say you put the battery on the charger. Did you observe if the charging cycle looked normal? Meaning battery alternating red, orange, green while it was charging? Were you using the rapid (gray) charger or standard (black) charger?
 
Photo of Prairiedog

Prairiedog

  • 9,344 Points 5k badge 2x thumb
Check the well where the battery sits and the bottom of the battery.  is there  anything that is keeping the battery from seating fully?  Try popping it out and back in again.  Also, are you pulling on the bail wire at the same time you are pushing the button?  Check under the deck to make sure the blade is able to spin freely and it is not jammed.  
Photo of N NAP

N NAP

  • 120 Points 100 badge 2x thumb
If the above suggestions don’t work, try opening and then closing (pressing) the two green clamps on the handle. Those clamps are pressing on mechanical switches. If proper contact is not made, it makes the mower inoperable