Mower dies no warning!

  • 2
  • Problem
  • Updated 5 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: duplicate

Well guess the fun is over! 

On my 3rd mow ego mower just up and randomly dies.  Battery light remains green Handle is fully extended and locked.  No grass buildup, grass is flowing normally out side discharge.

Sometimes normal startup procedure works other it just makes a clicking noise.  After a few attempts it restarts.  Runs for little bit and dies again. 

Any suggestions or should I just return it?  This was my 3rd mow and was starting to think this thing might actually do the job.


Photo of Doug

Doug

  • 286 Points 250 badge 2x thumb

Posted 5 years ago

  • 2
Photo of Eric

Eric

  • 496 Points 250 badge 2x thumb
I can imagine a few electrical problems that could cause that effect, but personally if it's been less than 90 days I'd just take it back to Home Depot and have them give you a working one as a replacement.  I'm sure the EGO customer service people would be pleasant enough, but retail stores offer return policies on defective merchandise for a reason, and it's typically vastly more convenient for the customer than an RMA process through the manufacturer.

That being said, I am not a technical expert on the mower mechanics; someone else may have a better idea to try first.
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 80,908 Points 50k badge 2x thumb
Official Response
Doug, we are sorry to hear about your mower.  It seems like you did everything correctly.  Please call our customer service department so we can further troubleshoot your issues.  We're available at 1-855-346-5656 Monday through Friday from 8:30AM - 8:00PM EST (Saturday and Sunday from 10:00AM - 6:00PM EST).  We're here to help!
Photo of Doug

Doug

  • 286 Points 250 badge 2x thumb
I just went ahead and returned my unit since I only had it a couple weeks.  I willing to give it another try hoping it was just bad luck.

Do I need to have someone remove my current registration on the returned mower before I register the new unit?



(Edited)
Photo of Mike Prince

Mike Prince

  • 60 Points
Bought an EGO mower on 4/5 and it died on 6/5. Took it back to Home Depot and they tested it out then replaced it. The replacment unit died on 7/4. EGO support was closed due to the holidy so I took it back to Home Depot and got my money back. I am hoping there is a generation 2 coming out that addresses the unexplained death syndrome.
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 80,908 Points 50k badge 2x thumb
Mike, we're sorry to hear about your mower.  We'd like to assure everyone that we are definitely investigating this mysterious "death syndrome" and we'll update this community as soon as we know more.
Photo of DB

DB

  • 60 Points
I am on my third mower as well.  Any updates on the mysterious "death syndrome" as you describe above?  Really like the mower, but getting tired of the trips back to Home Depot.
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 80,908 Points 50k badge 2x thumb
DB, we can definitely understand your frustration.  We would be frustrated too!!  We wanted to assure everyone that we are looking into this "death syndrome" and it hasn't been forgotten.  We wish we had a better answer but we promise, once we have a fix, we'll report it ASAP.  In the meantime, to be sure you get notified of any fixes we implement, be sure to register your warranties.  That's the fastest way for us to find you and notify you.
Photo of Seth

Seth

  • 90 Points 75 badge 2x thumb
Probably a different issue but I had similar symptoms. Found the cause to be related to the rail locks. Sometimes in taller grass, the handle would just collapse a little bit and push beyond the point of being able to restart and it acts in a similar way. Usually this happened with the right side rail latches popping up, but not always. (This is the reason I came here: looking for any tips on how to keep this unintended slip on the rails)

But anyway, since the issue described by these "dead" mowers is identical to what I witness with the handle has slipped, Perhaps this issue is caused by a malfunction in how the mower detects if the handle is fully extended?

If so and my suggestion solved it, thanks can be provided in extra batteries. ;)
Photo of SCDC

SCDC, Champion

  • 54,224 Points 50k badge 2x thumb
Seth, I think you nailed this one on the head. My handle locks have started to get a bit sloppy and the left one unlatches easy and stops the mower. Tempted to just tie wrap the things, I never collapse them. EGO's support will probably appreciate your post! I'm going to call in about my lose left latch on Monday. If that is all this is, the. Easy fix for EGO and probably a great thing they will look into improving.

I love this forum. You all are great.
(Edited)
Photo of Seth

Seth

  • 90 Points 75 badge 2x thumb
Well, Mike said they tried to start his at Home Depot, so I'm guessing it's the the sensor (and our slip here is a secondary issue), but I'd think both would be relatively easy to figure out. Hopefully this is the case and they've been focusing on the "core" of the mower and just didn't check the handle.

A latch fix would be great too, but unless there's some reason not to, I'd be more inclined to just bungee the latches (my storage shed's not big enough to not collapse and it's up some stairs too) unless the fix wouldn't require me driving it some service center.
Higher on my wishlist would be more specific indicators on charge level, estimated run time remaining, or maybe rear lighting so I can see how well it cut after dark without facing the mower back that way.
Photo of SCDC

SCDC, Champion

  • 54,224 Points 50k badge 2x thumb
Yeah, an actual countdown timer would be lovely. Or, a set of 10 LEDs . From green to yellow to red. 7 green, 2 yellow, 1 red.
Photo of Sharon Beasley

Sharon Beasley

  • 1,872 Points 1k badge 2x thumb
I just got the Ego mower today and was thrilled with it.  It stopped running sooner than I expected so recharged the battery.  Headed out a few hours later to mow some more and it started and then quit within a minute.  I noticed in the literature that if the heat of the battery gets to a certain degrees, it quits.  It is about 100 degrees today so I am wondering if that is why it is quitting since I mowed around 10 before the heat built up.  I guess I will go read the literature more.  I don't usually mow when it is this warm, but am so excited with the mower that I thought I could endure in a shady spot.   This could be a problem for people who can take the heat and want to mow when it happens to be hot.
Photo of SCDC

SCDC, Champion

  • 54,224 Points 50k badge 2x thumb
Hello Sharon,

Heat is a killer of all battery types. Your charge will not last as long in the heat, and the heat will slowly kill a batteries ability to hold a charge. That safeguard is on of the smartest things EGO could have done. Batteries are very expensive! I only mow in the evenings, and as the weather cools I am getting very long run times.

This past week has been the hottest we have had in South Carolina. I won't mow this week. Good luck with your modern work of art, and mow late evening, turn on those headlights. ;-).
(Edited)
Photo of Doug

Doug

  • 286 Points 250 badge 2x thumb
Just wanted to update this thread!

Second mower has performed flawlessly.    I have also bagged some and mainly now mulch with second unit.    No more side discharge falling off.  That didn't seem to be a problem with second unit however.

I am wondering if it was indeed an issue with the rail locks mentioned above.   When first mower was in service I was doing some remodeling.   Garage was full of cabinets parts etc.  To save space in garage first mower was being broke down and stored away .  Second mower I was done with remodel  and mower is  just being parked in garage with handle left in upright position.

This conversation is no longer open for comments or replies.