mower won't start up....

  • 5
  • Question
  • Updated 3 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: CS

my mower is less than 3 months old. yesterday when i went to mow my lawn - i put in the freshly charged battery, pressed that safety key and it wouldn't start. the green light came on, the blade started to go, then it just died and wouldn't start up at all after that. i let it sit a while, tried again NOTHING. up until yesterday it would stall out every time i hit a minor obstruction like a gopher mound or a branch that was hidden in the weeds. it would need 10 to 15 minutes 'rest' before it would start again. now i can't even get to go at all. need to know where to take it for repair...
Photo of Frank

Frank

  • 654 Points 500 badge 2x thumb
  • annoyed

Posted 5 years ago

  • 5
Photo of Frank

Frank

  • 654 Points 500 badge 2x thumb
and before you say it - YES to all of these:
1)    Does the battery display a green light when the indicator is pressed?
2)    Is the battery securely locked into place?
3)    Does the Mower headlight turn on when the light button is pressed? If not, check again to make sure the battery is fully locked into place.
4)    Are the handles fully extended to display the black lines on either side of the handle? If not, release the clasps and extend the handles the full distance.
5)    When starting the mower, be sure to depress the safety down before pulling the bail handle. 
Photo of Blue Angel

Blue Angel, Champion

  • 179,968 Points 100k badge 2x thumb
Frank, if you've gone through all the common sense troubleshooting tips your mower likely has something wrong with it. Give Ego a shout on Monday for instructions on how to proceed:

http://egopowerplus.com/pages/contact-us
Photo of ashnazg

ashnazg

  • 192 Points 100 badge 2x thumb
The only "clarification suggestion" I'd make is to open and close both green clips that hold the handle in place. One of my clips fits poorly, so it eases itself loose every minute or two, thus disabling the motor.
Photo of Robin Kennedy

Robin Kennedy

  • 60 Points
I'm having the same problem. What green clips are you talking about???
Photo of ashnazg

ashnazg

  • 192 Points 100 badge 2x thumb
The green clips that are halfway down each side of the pushbar. They lock the length of the pushbar in place. They also act as kill switches if they wiggle unlocked. I ultimately resorted to wrapping each one with a bandana to keep them from coming loose while mowing.
Photo of Blue Angel

Blue Angel, Champion

  • 179,968 Points 100k badge 2x thumb
Anyone with warranty coverage on their mower qualifies for a handle clip upgrade. Get in touch with Ego Customer Service and they'll send you an upgraded handle clip set. They're easy to install and much more robust than the originals.

Edit: this applies to the 20" mower. :-)
(Edited)
Photo of Frank

Frank

  • 654 Points 500 badge 2x thumb
thanks for the link to the contact info Blue Angel... i'll definitely give em a call first thing tomorrow. 

And ashnazg - THANKS - i'll give that a try today, before i call em... i don't think that's it - but i could certainly be wrong - worth a try anyway..
Photo of Sharon Beasley

Sharon Beasley

  • 1,872 Points 1k badge 2x thumb
My handle clip often comes loose also.  Annoying, but I still love my EGO.  I didn't get to use it too many times after i bought it last year, so look forward to getting it out here real soon.  Should already be mowing.
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 81,048 Points 50k badge 2x thumb
Sharon, we have replacement clips available that we'd be happy to provide you.  Give us a call at 1-855-346-5656 and we'll get some ordered for you.
Photo of Sharon Beasley

Sharon Beasley

  • 1,872 Points 1k badge 2x thumb
Thanks for offering the replacement clips.  For now, I don't think they are bad enough to worry about.   Great that people can get answers about the EGO.   I will probably using it today or tomorrow for the first time this season.  Can't wait.  It is still like my toy.
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 81,048 Points 50k badge 2x thumb
Frank, we look forward to hearing from you.  Our customer service team is ready and standing by at 1-855-EGO-5656 (1-855-346-5656). We're available Monday through Friday from 8:30AM - 8:00PM EST (Saturdays and Sundays from 10:00AM - 6:00PM EST).  We're sorry we didn't get a chance to respond to you in time yesterday in order to get you taken care of right away.
Photo of Frank

Frank

  • 654 Points 500 badge 2x thumb
Gee, yesterday was Sunday - i certainly didn't expect a response on Sunday. thanks.
i'll call this morning.
Photo of Frank

Frank

  • 654 Points 500 badge 2x thumb
so, i spoke with someone a few minutes ago.  y'all never got my warranty card in the mail so she took care of that for me first, which i really appreciate.  then we did some troubleshooting and we got it working again. turns out it WAS a loose clip...
THANKS!
Photo of senapatiyou .

senapatiyou .

  • 110 Points 100 badge 2x thumb
I have the same problem with my mower. Please tell me what troubleshooting was done that helped to get the mower working again?
(Edited)
Photo of Frank

Frank

  • 654 Points 500 badge 2x thumb
unclip the clips on the handle. make sure the handle is pulled all the way out - reattach the clips. worked just fine for mine.  apparently the handle will slide JUST ENOUGH to cause the safety to kick in/
Photo of Sharon Beasley

Sharon Beasley

  • 1,872 Points 1k badge 2x thumb
Also, note that there are holes in the handle which the clips have a part that slips into those holes.
Photo of senapatiyou .

senapatiyou .

  • 110 Points 100 badge 2x thumb
I checked with the clips but it just won't start. Is there any way to test if the motor is working or not? Amy suggestions? Is there a service center around zip code 98052?
Photo of Sharon Beasley

Sharon Beasley

  • 1,872 Points 1k badge 2x thumb
Make sure you pushed the battery down far enough. Is the green light showing to indicate the battery is making a connection? Make sure you pull the safety handle back and then depress the key.  Hope you get it going soon.
Photo of senapatiyou .

senapatiyou .

  • 110 Points 100 badge 2x thumb
Yes, The head lights turn on when I press the LED button on the mower.  I checked all the possibilities listed by Frank in the beginning of this thread.
(Edited)
Photo of Frank

Frank

  • 654 Points 500 badge 2x thumb
just do what i did - CALL them...
they will tell you where to take it in for repair if they can't help you on the phone.
1-855-346-5656
Photo of John Lavin

John Lavin

  • 234 Points 100 badge 2x thumb
I doubt that is very good to run over gopher mounds and tree limbs. That's got to cause some issues.
Photo of senapatiyou .

senapatiyou .

  • 110 Points 100 badge 2x thumb
I decided to repair it myself as I did not get a repair shop near by.  I opened up all the screws holding the bail handle. I found a spring holding the safety key in place was the culprit. All the components are well designed but they could use a better spring - the weakest and wackiest part in the entire safety mechanism. Anyways, the mower is working now.
(Edited)
Photo of Judy Ferraiolo

Judy Ferraiolo

  • 140 Points 100 badge 2x thumb
Finally a post that does not assume we are all stupid.  I will try your suggestion.  Thanks.
Photo of Blue Angel

Blue Angel, Champion

  • 179,948 Points 100k badge 2x thumb
Judy, the reason for all of the repetitive suggestions is because those who are trying to help have no idea what the person having difficulties has or has not tried. Also, several of the common troubleshooting steps will often fix the problem, for example, making sure the handle is completely and fully extended before locking the tabs into place.

Everyone on this board, save the Ego Customer Service reps, are just regular people trying to help. Many times something simple is overlooked, and we're just trying to make sure the issue is not one of those things before escalating it. :-)
(Edited)
Photo of SLG

SLG

  • 588 Points 500 badge 2x thumb
This is exactly my concern for ego product, the warranty. It is a great product. But the warranty is not on par with the product yet. My battery died and it took two weeks to get replacement. I read here that another user mower died and it took almost 6 months.  This kind of post make me worry about the product warranty service the frustration of dealing with the shipping, waiting.

I wish EGO could provide similar 5 year hassle free warranty. That would be awesome!
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 81,048 Points 50k badge 2x thumb
Hello Leigang! Thank you for your post and we appreciate your feedback regarding our warranty process. Please know we do our very best to ensure that the 5 year warranty on our tools, and 3 year on batteries and chargers, are hassle free. The six month delay for one of our customer's warranty claim was due to an error with the service center. This situation was surprising to us, as it was definitely not within our guidelines, and we have since remedied the situation. We do apologize that you had to wait so long for your replacement battery to arrive, but our shipping times have drastically decreased so there is no longer a two week wait period for replacement items. 
Photo of Mike Bielak

Mike Bielak

  • 90 Points 75 badge 2x thumb
Our ego lm2100 will not start. bought 4-14-16, registered 4-16-16, NLM31512012.  In use about a year (not used Nov to April).  Battery has green light, cycled handle extension and clips, cycled extension, blade spins freely by hand, running lights will come on when turned on with switch, battery is locked in place and 100% charged by charger, pushed switch down before handle cycled - in short all trouble shooting completed.  Noticed only 3 connections in battery bay on mower instead of 4 like charger and slots in battery, but see both 3 and 4 connections in battery bay in online clips.  Grass is growing and will have to borrow neighbor's gas mower.  Had gas Snapper for 28 years and gave to my son with very few problems.  I am a little disappointed right now.  Next Steps?  Mike B.
Photo of Jacob

Jacob

  • 64,940 Points 50k badge 2x thumb
So. With the key pressed, when you pull the bail handle back, do you hear a click? Like the bail handle is engaging a switch?

If so the top portion is ok.

Either the handle clips on the left side arent engaging the small switch. Take the handle clamp on the left side apart to see if the mechanism is working correctly or not.

Other possiblility is the motor controller or the switch in the handle PIVOT assembly. Much harder to access.

There have been reports of a bad connection at a plug but i only have the 20" so someone else with the 21" can chime in.
Photo of Mike Bielak

Mike Bielak

  • 90 Points 75 badge 2x thumb
We hear a click when pulling the handle with key pressed.  I am hoping to get some satisfaction from EGO before I start taking things apart.  I will either borrow back my old mower from my son or borrow the neighbor's gas mower.  Thanks for comments and will try them if I cannot get input/satisfaction from EGO or Home Depot. Mike B.
Photo of Jacob

Jacob

  • 64,940 Points 50k badge 2x thumb
I wouldnt take anything apart besides the left handle clip. I say this because EGO will send out replacements to people who are having issues, and let the people replace the clips on their own. You can wait til tomorrow but i would call the moment they open as they will be flooded with calls im sure.

Since you hear that click in the bail handle that rules out needing to take the top portion apart.

Is the left handle clip green piece broken off at all?

I will take a look at mine to see if there is a way to do this without disassembly.
Photo of Mike Bielak

Mike Bielak

  • 90 Points 75 badge 2x thumb
No breaks or cracks in left clip.  By left clip, I assume you mean left clip from front of mower which wrapped wire harness runs through.  And again, thanks for forum response and input.  

I tried calling for warranty yesterday, but could not get through after online for 15 minutes or so.  Hit "O" to leave message and their voicemail is FULL !  Kind of makes me wonder why. EGO is not building a lot of confidence in their product or their service/company.  

Mike B.
Photo of Jacob

Jacob

  • 64,940 Points 50k badge 2x thumb
I have heard cases where something came loose in there where the switch didnt contact the clamp. Ill check in a bit. My 3 yr old is consuming my day
Photo of Jacob

Jacob

  • 64,940 Points 50k badge 2x thumb
So when you extend the handles, the telescoping pieces, you will hear a click inside by the wires. Listen for that.
Photo of Mike Bielak

Mike Bielak

  • 90 Points 75 badge 2x thumb
yes it clicks when handle is extended.  will try to contact them for warranty direction.  Thanks.  Mike B.
Photo of (a)Typical Engineer

(a)Typical Engineer

  • 26,632 Points 20k badge 2x thumb
Here are two threads, the first is a technical comparison of the old and new style clips, but with a 2016 mower I would expect it to have the new style; but you could use the instructions in the second link to disassemble and INSPECT for any damaged parts.  As said above, there are official Ego instructions, so disassembling for inspection and troubleshooting purposes should not void your warranty:

https://community.egopowerplus.com/ego/topics/20-mower-handle-locking-clamp-v2-upgrade-review

https://community.egopowerplus.com/ego/topics/20-mower-handle-locking-clamp-instructions
Photo of (a)Typical Engineer

(a)Typical Engineer

  • 26,632 Points 20k badge 2x thumb
Here are two threads, the first is a technical comparison of the old and new style clips, but with a 2016 mower I would expect it to have the new style; but you could use the instructions in the second link to disassemble and INSPECT for any damaged parts.  As said above, there are official Ego instructions, so disassembling for inspection and troubleshooting purposes should not void your warranty:

https://community.egopowerplus.com/ego/topics/20-mower-handle-locking-clamp-v2-upgrade-review

https://community.egopowerplus.com/ego/topics/20-mower-handle-locking-clamp-instructions
Photo of Amber F.

Amber F., Official EGO Rep

  • 68,270 Points 50k badge 2x thumb
Please let us know what happens, Mike. 
Photo of Sergio DJ.

Sergio DJ.

  • 100 Points 100 badge 2x thumb
I had the same issues as my mower didn't want to start or do anything. I tried the clips adjustment and it was not that but a loose spring in the handle compartment. I unscrew the 10+ screws and there was the culprit.
The problem was that the spring was slightly out of place and didn't allow the key to push the piece of plastic all the way in to connect with the black rod and turn on the mower. I corrected the spring location, closed the plastic housing and all was good. Watch the video for reference.

https://youtu.be/RL3TVlf9eVI
Photo of Blue Angel

Blue Angel, Champion

  • 179,948 Points 100k badge 2x thumb
Awesome!  What a great effort!

Ego, I think this guy deserves a T-Shirt or something!!! :-)
Photo of vicki topel

vicki topel

  • 60 Points
Champion of what? Jerks? By the way. Champ, not a guy
Photo of Blue Angel

Blue Angel, Champion

  • 179,948 Points 100k badge 2x thumb
Um, what seems to be the problem, Vicki? For the record, I was commending Sergio on his post, who sounds like a guy in the video, to me at least.
Photo of szwoopp

szwoopp, Champion

  • 105,550 Points 100k badge 2x thumb
??, but I am sure you have been a jerk about something in your life, so just apply the reprimand to that. :)
Photo of Amber F.

Amber F., Official EGO Rep

  • 68,272 Points 50k badge 2x thumb
Thank you very much for this fantastic info, Sergio! 
Photo of Blue Angel

Blue Angel, Champion

  • 179,948 Points 100k badge 2x thumb
Guilty as charged, szwoopp! :-)
Photo of Jacob

Jacob

  • 65,000 Points 50k badge 2x thumb
Nice job!!!. Thanks for sharing

This conversation is no longer open for comments or replies.