mower won't start

  • 2
  • Problem
  • Updated 2 months ago
  • In Progress
I bought my 21” SP mower on 4-14-19 at Home Depot.  This past week (Sept 3) I found that my mower will not engage the blades.  When this first happened I was in the low position on the handle bar.  I started fiddling with the handle bar and moved it to the middle position, it did not work there either, until I lifted up on the handle bar in the middle position. The blades would engage but every time I pushed down on the handle bar to turn around, the blades would stop.  Once turned  around and I lifted the bar, and the blades engaged.  Now this week (before I could contact the Warranty Dept) I went to mow and the blades would not engage with the handle bar in the low or middle positions.  I moved it to the top position and it would not engage until, just like the comment above about the middle position, if I lifted the handle bar it would engage the blades.  However, same issue - every time I pushed down on the handle bar to turn around, the blades would stop.  I would again turn it around and lift the bar, and the blades would engage.  I just went out to check on it again (Sept 9) and now it will not engage the blades in any of the three operating positions, low, middle, high.  HOWEVER, it will engage the mover blades when I move the handle bar ABOVE the high position.  This is no good as you cannot use the mower in that position as the handle bar is not in a locked position. I have documented this issue via a video that I took to demonstrate the issue with my mower. My opinion is, there is a short of sorts or some connection issues between the handle bar the engagement of the mower blades.  My issue is the same as mentioned in the you tube video link from Mike and Da Dude's comment from 2 days ago.
Photo of IAPackFan

IAPackFan

  • 150 Points 100 badge 2x thumb

Posted 3 months ago

  • 2
Photo of szwoopp

szwoopp, Champion

  • 106,132 Points 100k badge 2x thumb
You should contact Ego customer service to get the mower diagnosed and repaired under warranty if needed.   Call first thing in the morning if you can to minimize any wait time.
They do good work and will take care of you.

They can be reached at 1-855-EGO-5656 (1-855-346-5656) from 8:30AM - 8:00PM EST (Monday - Friday) & 10:00AM - 6:00PM EST (Saturday & Sunday).
Photo of Kenny Mars

Kenny Mars

  • 896 Points 500 badge 2x thumb
My take on this issue is a faulty safety relay in the handle bottom mount. Your going to have to return your mower to your Home Depot to send to EGO to have your relay replaced. Mine worked for 2 seasons before we folded it for storage. Then all I got was a yellow flashing light. No motor or blade would engage. Took a bit over 4 weeks to get it back.
Photo of soakssr

soakssr

  • 138 Points 100 badge 2x thumb
It may be a silly question, but did you check if the upper handle was in the fully extended and locked position?
Photo of IAPackFan

IAPackFan

  • 150 Points 100 badge 2x thumb
yes, i did check that as that was mentioned in the manual as a potential issue
Photo of mike

mike

  • 316 Points 250 badge 2x thumb
Thanks for the s/o IAPackFan. I've been checking up on here about every other day to see if any other mowers "just stopped working" so I can post that YouTube link I found after I ran across the same problem. Ego made it right with a new mower. Took a bit over 2months but whatever.
Photo of IAPackFan

IAPackFan

  • 150 Points 100 badge 2x thumb
I think the prior submissions about this problem have heightened EGO's awareness on this problem as customer service was right on my issue when I called and since I had registered my warranty and submitted my purchase receipt when I submitted my warranty, they had all they needed to send me a replacement mower.
Photo of IAPackFan

IAPackFan

  • 150 Points 100 badge 2x thumb
as a follow up, I called the Warranty Dept just after I posted this and they are shipping me a new mower... to arrive in about a week with a return shipping label to allow my to send my current mower back to EGO.  I appreciate that customer service!  thanks
Photo of szwoopp

szwoopp, Champion

  • 105,770 Points 100k badge 2x thumb
Ego cs does a great job !
Photo of Andy Ewing

Andy Ewing

  • 170 Points 100 badge 2x thumb
I'll be call EGo CS this afternoon, when I can be at home with access to my mower, with the exact same problem.  Hopefully I experience the same level of service that others have when encountering this problem.  I'm also thinking that once I have my repaired or new mower, whichever, I will no longer fold the handle for storage.  Instead, I'll leave it extended.  Takes up more space, but I'll bet it prevents the problem from happening again.
Photo of Andy Ewing

Andy Ewing

  • 170 Points 100 badge 2x thumb
Update - I spoke to CS this afternoon. Since my mower is less than a year old they are sending replacement and an authorization to return the old one. Great customer service.
Photo of szwoopp

szwoopp, Champion

  • 102,286 Points 100k badge 2x thumb
Thanks for the update Andy