My mower won't start and I need help with repair/replacement direction.

  • 3
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Out of date

I have a 2 year old 20inch mower, that will not start.  The battery is fine (it works well with my EGO blower).  I have been through the typical troubleshooting steps - first online, and then on the phone with EGO support (after lengthy holding times).   They directed me to a Home Depot for service (and implied that it should be quick and simple).   I went there; they are not equipped to service it themselves, and they suggested that they could ship it out, but that service may take up to 8 weeks.   I can't lose the mower for 8 weeks at this time of year (the cost of a lawn service would be higher than simply replacing the mower myself), so this isn't a real solution.  I called EGO again (and again waited through their lengthy hold periods), and spoke with a rep named Jorge.   He said that he would follow up via a supervisor and call me back within 24 hours to let me know about EGO paying for a replacement mower in the short term.    24 hours came and went, and I have not received a call.    I attempted to call again, and have been on hold all the way through the closing time of 8 PM Eastern.    I have always loved the products and told everyone I could about how wonderful they are, but this customer service experience has been atrocious.   I'm hoping that I can achieve some positive result through this post.   My mower is registered with EGO.   EGO, please respond here or call me (my number is part of my registration listing) ASAP.   I'm hoping this can be resolved in a positive way soon so that I can continue to purchase more EGO products.
Photo of Mike Conklin

Mike Conklin

  • 290 Points 250 badge 2x thumb
  • frustrated

Posted 3 years ago

  • 3
Photo of Paul

Paul

  • 754 Points 500 badge 2x thumb
Im sure you will get a reply and they will take care of you. 

I agree though that 8 weeks is an unacceptable turn around time. Frankly the model should be that if Home Depot cannot fix the mower themselves, that they send it back for refurbishment and Ego sends you a new mower. 

Under no circumstances is it reasonable to expect a customer to wait that long for service. 
Photo of Jacob

Jacob

  • 64,880 Points 50k badge 2x thumb
When you push down the key, then the handle to turn it on, does it make a click sound? Also do the headlights work?
Photo of Robert Waters

Robert Waters

  • 120 Points 100 badge 2x thumb
EGO support is hit or miss. There are unacceptably long waiting periods to get someone on the line and they don't always follow up as promised. When they do, they're great. Have you tried making sure the clamps on the mower handles are completely and tightly connected? If not, it could cause the problem you're having. I've heard that sometimes those clamps or clips need to be replaced.
Photo of Sharon Beasley

Sharon Beasley

  • 1,872 Points 1k badge 2x thumb
Hope you can get it resolved soon.  I would not like going 2 months without use of my mower either.
Photo of Keith Harvell

Keith Harvell

  • 226 Points 100 badge 2x thumb
Having issues with mine also. It's not the battery. It's fully charged and green. The headlight works, the clamps seem fine and lock. I don't notice any clicking sound when pushing the key down and handle. Any ideas anyone?
Photo of Jacob

Jacob

  • 64,880 Points 50k badge 2x thumb
There should be a click sound when you have the green key pushed down and start handle pulled back, no sound when the key is not pushed down.reply back when you try this.
Photo of Jacob

Jacob

  • 64,880 Points 50k badge 2x thumb
Ok here is why you should hear a click sound when the. Key is pressed.



The first image is the key pressed in. The little black thing slides into position so the switch can get activated. Look down the hole of the key. There should be a tab like this.

(Edited)
Photo of Dave .

Dave .

  • 21,706 Points 20k badge 2x thumb
Mike, did you go to a HD Rental Center?  They are the only HD entities that MAY be equipped to service Ego products (I've already had discussions with HD employees at their Rental Center).  A HD store, in and of itself isn't going to do diagnostics or repairs--you have to take it to one of their rental centers, and even then, repairs may or may not be done there depend on what's wrong with the unit.
(Edited)
Photo of Mike Conklin

Mike Conklin

  • 290 Points 250 badge 2x thumb
Thanks for all of the responses - I did go to the HD rental center.   It isn't the typical clamps issue.  The headlights do work.  I do not hear the click when the key is pressed, at all.   
Photo of Jacob

Jacob

  • 64,880 Points 50k badge 2x thumb
The click is only when the key is pressed and the bail handle is pulled to start. Then you should hear a click. If not. The issue is the black piece that engages the switch. Look down the key hole. Do you see a small black plate as shown in my pictures? Take a picture of the keyhole like i did in my previous post. If you dont, i have a suggestion for you.
Photo of Mike Conklin

Mike Conklin

  • 290 Points 250 badge 2x thumb
Thanks Jacob. I do hear the click now when inserting the key and pulling the handle. The mower actually just started, but died after a second or two, and won't restart for the moment. Attached is a picture of the keyhole.
Photo of Jacob

Jacob

  • 64,880 Points 50k badge 2x thumb
Ok. Sounds like its startup check is failing. First, does the blade spin freely? Next, try taking off the blade and start it without the blade attached. Just curious. Sounds like the motor controller is failing, or the motor is sensing too much load on startup. I am hoping something is stuck between the motor shaft and the bearing. This would be a easy fix. But when are they ever.
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 81,028 Points 50k badge 2x thumb
Hi Mike, one of our customer service leads is going to call you today.  We're so sorry for the lack of a return call.  We're going to talk to Jorge today about this as well.
Photo of Mike Conklin

Mike Conklin

  • 290 Points 250 badge 2x thumb
Thanks Jennifer, I'll look forward to the call.     Jacob, thanks for your continued responses, I appreciate it :).   The blade does spin freely, and there isn't a difference in starting it with the blade attached or not.
Photo of Jacob

Jacob

  • 64,880 Points 50k badge 2x thumb
Alright. I was hoping it was something that could be fixed without going this route. Good luck.
Photo of Mike Conklin

Mike Conklin

  • 290 Points 250 badge 2x thumb
I just received a call from EGO, they have agreed to replace the mower on a one time basis.  Thank you EGO!   Now I can go back to looking forward to the snowblower this fall :)
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 81,028 Points 50k badge 2x thumb
Mike, we're glad that we could get you taken care of and thanks for giving us a chance to make this right for you.  We look forward to hearing how much you like the snow blower later this year.

This conversation is no longer open for comments or replies.