Mower won’t start

  • 5
  • Problem
  • Updated 1 week ago
  • Solved
Got done mowing my front lawn, went to the back and the mower wouldn’t start. Checked battery. Fine. Switched batteries. Nothing. Let mower chill for the evening because I was over it.
Now. Checked under it, nothing blocking the blade. No build up anywhere actually, keep it clean. Have checked all latches and levers and they’re all in place as they should be. No error lights on the mower or any of the batteries. Have tried folding it up and resetting all the patches essentially. Bail bar still clicks when power button is depressed and then pulled. Customer service still isn’t answering. Been an all day event (called at 8am and they still haven’t called back).
Photo of Bob Jobe

Bob Jobe

  • 110 Points 100 badge 2x thumb
  • pissed and confused

Posted 2 months ago

  • 5
Photo of mattysa

mattysa

  • 494 Points 250 badge 2x thumb
My situation is a bit different than probably the rest of you.  I brought my mower at HD same as everyone else but then moved back to Australia and took it with me.  Of course my warranty is not recognized here and there is no service partner in the area that I live in so there really is no other option that to fix it myself.  I am an electrical engineer so nothing in these machines scare me so I found the company here that acts as 3rd party warranty provider and I can get parts directly from them. They also sent me the exploded part list and view.  I can only attach a jpg here so the quality is crap but I actually have the excel sheet.  If someone can tell me how to upload that I will.



Photo of szwoopp

szwoopp, Champion

  • 88,176 Points 50k badge 2x thumb
That is an awesome resource.  I think you would have to put the file in dropbox or other similar cloud storage system and then post the link here.  As you found you can only upload image files to this board.
Photo of Vincent

Vincent

  • 122 Points 100 badge 2x thumb
I appreciate all the informational posts but my mower is new and I'm not going to chance opening it up. I see some others have had the same issue; worked at first, then wont start again. Is there a common issue I can look for?


(Edited)