LM2100SP self-propell working, but no mowing function. PLEASE POST HERE IF YOU HAVE or HAD THE SAME

  • 9
  • Problem
  • Updated 2 weeks ago
  • In Progress
I purchased this mower on 3/15/2019. I have used it only several times with no issues. I went to use it today and the self-propelled function works just fine, but the mowing piece no longer functions. I checked the troubleshooting section on Page 48-50 of the guide and followed all the procedures. On Page 50 it mentions to check the bolt on the bottom mower blade to ensure it's between 36-43 ft-lb torque (good thing I have a torque wrench). It was interesting set to 40 ft-lbs of torque. After waiting 4 hours to receive a call back from the support staff, I was told they have to escalate this to management and that management will not be in until tomorrow during regular hours. In the mean time I figured it made sense to make this post and see if any others have experienced this issue to see if it's more wide spread. I noticed another user today having exactly the same issue. So now I'm curious if it's a much bigger problem. The support staff said this is not an issue she was aware of and that there are currently no recalls on this product. Thanks to all that have this and please post if you have the same problem.
Photo of MattG

MattG

  • 376 Points 250 badge 2x thumb
  • unhappy

Posted 5 months ago

  • 9
Photo of MattG

MattG

  • 376 Points 250 badge 2x thumb
Photo of Frank Woodbery

Frank Woodbery

  • 3,832 Points 3k badge 2x thumb
Apparently EGO killed access to that thread.
Photo of MattG

MattG

  • 376 Points 250 badge 2x thumb
Did they really kill the thread from the other user? For the record then, there was 3 users in that other post with the same issues I posted here. I am taking screen shots of this post in case someone thinks it's right to remove this post. Guess the 1st amendment doesn't stand any longer.
(Edited)
Photo of Ken

Ken, Champion

  • 73,200 Points 50k badge 2x thumb
The First Amendment applies to the government, not to privately owned companies.
Photo of Kenneth Wood

Kenneth Wood

  • 334 Points 250 badge 2x thumb
I think Home Depot has a 90 day return policy, even longer if you paid with a home depot card.
Photo of szwoopp

szwoopp, Champion

  • 98,382 Points 50k badge 2x thumb
Kenneth is correct.  And this is generally the fastest and easiest way to get a replacement tool if you are with in the HD return window.
Photo of Peter Stevenson

Peter Stevenson

  • 212 Points 100 badge 2x thumb
Take the mower for a refund. Do not get it repaired. If you still want one, just purchase a new one.
(Edited)
Photo of MattG

MattG

  • 376 Points 250 badge 2x thumb
I plan on doing that.
Photo of Frank Woodbery

Frank Woodbery

  • 3,792 Points 3k badge 2x thumb
With an HD credit card purchase they advertise a one year hassle free return window.
Photo of MattG

MattG

  • 376 Points 250 badge 2x thumb
For the record 4 people have replied in this thread and the other one that started this whole issue. The total count of users is up to 5 now including myself. Even though I plan on returning it, who's to say the issue will not happen again. Most everyone that mentioned they had the same problems have purchased within the past 12 months. Roll of the dice I guess at this point.
(Edited)
Photo of Frank Woodbery

Frank Woodbery

  • 3,832 Points 3k badge 2x thumb
Good point Matt. If you have the HD card it's the perfect opportunity to use it to get the one year return window. While many here have had good success with EGO mowers, I would keep the gas mower around as backup whenever the EGO stops working. I dont have the patience for stuff that doesn't work reliably.
Photo of MattG

MattG

  • 376 Points 250 badge 2x thumb
I can appreciate everyone's reply about returning it to HD for a replacement or refund and as soon as I speak with EGO management I will. In the consumer world of things if a person is within their return window they should absolutely leverage it. For those that read this post it's great that if they want to return/replace the product within the return window, but more to see if my issue and 4 others with the same problem is a little bigger issue. Maybe it's the 25+ years I have working in tech and the past 14 of those years working at the largest networking company in the world as an engineer that makes me intrigued that the issue just seems to be to coincidental and the actual faultiness is something more rooted. For the self-propel to still work, but the blade to no longer engage after a few uses just doesn't seem to sit with me well. And I get it, there a tons of variables that could have caused it to fail. If anyone reading this today, tomorrow, week, month or even a year from now sees it, hopefully it helps them and hopefully they are lucky enough to be within the return window. BTW, I don't need another store card in my wallet, but I do appreciate that HD offers the one year hassle free capabilities and it might help someone else reading this.
Photo of szwoopp

szwoopp, Champion

  • 98,106 Points 50k badge 2x thumb
The SP and the blade always operate separately.  You can use the SP to move your mower without the blade engaged and/or you can mow without engaging the SP.
So for one to work and the other to not operate is not really an oddity.  They are separate systems with separate motors and separate safety switches.
(Edited)
Photo of MattG

MattG

  • 376 Points 250 badge 2x thumb
Update - 1:50pm -7 PST on 4/30/2019: After 36 hours of waiting to hear back from escalations I made the command decision to return the product to Home Depot. Now here is where the story gets interesting. Yesterday I received two emails from their support email saying my cases where updated. This morning I was curious about the updates, so I logged back into EGO’s support site and found that both my cases where now closed and there is NO WAY to actually see any information on the case. So this afternoon I tried calling and waited for like 40 min for someone to pick up and no one did, so I opted for the call back feature. After that I just decided to take it back to Home Depot for a replacement. Thank god I was under the 90 days return policy. I'm really hoping I don't hit the same issues with the replacement. But I did want to express my thoughts about their Customer Service. Once I returned home with the replacement mower, I tried calling Customer Support again. I again waited for like 30 minutes with no one picking up and I opted for the return call. Now that’s 2x calls today with waiting on the line for a support person with no response and opting both times to get the call back. I finally get a call back around 12pm PST (3pm EST) from a nice lady, but ultimately she could not say why the cases where closed and all she could do was open another case. She did go speak to her team leader and the team leader said he would like me to ship the product directly back to them. Now at this point I find this weird seeing they know I’ve only owned it for around 40 days and that I could just return it to Home Depot, which is what I did. I understand they probably want to take a deeper look at my particular mower, but I explained that their support has been not so great up to this point and that I ended up returning it back to the store this afternoon. I gave them the store information and told the girl about the 4 other people on this community site that are experiencing the same problems and all those same models where purchased within the past 12 months. She toke note of it and I’ll assume it goes into an abyss at this point also.

Anyway I figured I’d share my experience and hopefully anyone else reading this post experiencing the same issues with this model will have something to go back to EGO support with.

(Edited)
Same issue. Just purchased this mower at end of March. Used it twice. Today, blade will not engage.  Sounds like I will have to take it back. Very disappointed.  ~ Dallas
Photo of Da Dude

Da Dude

  • 62 Points
Purchased mine in May 2019 and ran into this issue today. Not happy because I'm past the 90 day return policy for HD, so hopefully the Ego support is good.

Was loving this lawn mower and recommending to all my friends and family. May regret that.
Photo of szwoopp

szwoopp, Champion

  • 99,460 Points 50k badge 2x thumb
Ego support is great.  HD repairs are aggravating. Call Ego cs first - they will set you up with HD repair if that is what is needed.  Try to convince your local Ego repair dept to take care of it in house.  Mine did and got it back to me in less just over a week.  Just need to find a HD repair center with a good repair person.  If you live in a metro area I would call several near by HD and find the best repair person I could.
Good luck
Photo of mike

mike

  • 316 Points 250 badge 2x thumb