LM2100SP runs but doesn’t cut the grass

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
I charged up the battery, put the bag on after removing the mulch attachment. I turned it on and it self propelled across the nearest overgrown 6 inch high or so Centipede and St Augustine yard, barely putting any grass in the bag. It looked as though I had not cut it at all. I even tried several times to cut 9 or so inch tall dandelion and all it did was lie it down on the ground after the sixth or seventh time; it did not cut it.

It looks like I have no choice but to return it to Home Depot because the phone line for ego put me on hold for five hours without answering and didn’t respond to my message. They tell you on the machine to come in here but then you find message warning that they will hide any “grievance.” This is my first use of the mower and I counted on it to work. The landlord wants me to cut the lawn. I have never owned a mower that didn’t cut the grass before. Very disappointed.

I had the lowest setting on after trying the middle setting and it never made any clear path of any sort that showed it had cut the grass. What have I failed to do? I will keep the mower only if I can get a quick answer from ego or someone that leads to it working. I’m overdue cutting the lawn.
Photo of Mary


  • 308 Points 250 badge 2x thumb
  • shocked

Posted 2 years ago

  • 1
Photo of David Love

David Love

  • 200 Points 100 badge 2x thumb
Official Response
Mary, I also just purchased a self propelled unit like you did.  Like you the motor did not start for me.  But it did start for my wife.  The "trick"  seemed to be in the black safety bar.  She moved it several times and finally it started.  
My concern is that it only cut 1/2 of my "small (50x50) back yard before the battery quit.  
Hopefully it wasn't charged well enough.