LM2022SP -- Self Propelled doesn't operate about 20% of the time

  • 2
  • Problem
  • Updated 2 months ago
This is my second season with the LM2022SP self-propelled brushless mower. Fantastic mower. The only thing that's driving me absolutely nuts is that the green self-propelled lever won't work about 20% of the time. I have to pull the green lever two, three.... sometimes four times before the mower will take off moving. It's driving me crazy having to pull the lever multiple times to get the self propelled mode to engage. Is anyone else having this intermittent problem and what is the fix for it?
Photo of Carl Johnson

Carl Johnson

  • 120 Points 100 badge 2x thumb

Posted 2 months ago

  • 2
Photo of William E Hanson

William E Hanson

  • 19,356 Points 10k badge 2x thumb
Carl, release the SP handle a step or two before you turn the mower around or need to pull back. It's a built-in delay. Once you start that routine, it will become second nature.
Photo of Carl Johnson

Carl Johnson

  • 120 Points 100 badge 2x thumb
Thanks, William. Next cut, I'll try releasing the SP handle a step or two before turning around and see what happens. Thanks for the advice.
Photo of Jim McD

Jim McD

  • 694 Points 500 badge 2x thumb
Carl - I had the same issue last year with my LM2022SP when it was brand new. I called customer support and they sent me a new replacement mower and emailed me a pre-paid Fed Ex return shipping label (I used the same box from the replacement mower). The replacement mower had the same issue and this process went on for 5 different LM2022SP mowers! Finally the 5th mower only has this issue about 1 out of 75 times and I decided to live with it. After about the 2nd replacement Ego support questioned if I was doing something wrong. I sent them a video of the SP malfunctioning and they didn't question me again. I feel your pain Carl, this was a real hassle, and like you, everything else about the mower is fantastic. My main issue now is the variable SP speed control is either too slow or too fast. More fast or slow, rather than variable. Back to the replacement process, it was always the bare tool replacement. I kept my original battery and charger. I hope you get your problem resolved.  
Photo of Carl Johnson

Carl Johnson

  • 120 Points 100 badge 2x thumb
Jim, I agree with you the speed control is VERY sensitive. A fraction of an inch one way, it's too slow. A fraction of an inch the other way can be too fast.  It should have been a "coarser" adjustment.  I'm going to try the SP trick shown above next week and see if that fixes my issue. Thanks.