line trimmer stops after 25 minutes continued use

  • 1
  • Problem
  • Updated 2 years ago
  • In Progress
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Duplicate

after 25 minutes it stops working
Photo of Scott Keon

Scott Keon

  • 70 Points

Posted 2 years ago

  • 1
Photo of jerralw

jerralw

  • 82 Points 75 badge 2x thumb
I'm having the same problem, only my trimmer stops after 2 seconds. Hopefully, we can find resolution soon.
Photo of (a)Typical Engineer

(a)Typical Engineer

  • 26,512 Points 20k badge 2x thumb
what model trimmer?  what battery size?  what are the indications on the battery (red/green/etc)?  what are your working conditions (long grass, short grass, etc)?
Photo of David HD

David HD, Champion

  • 34,738 Points 20k badge 2x thumb
Official Response
Scott, if you were to contact Customer Service (CS) regarding your post, they will probably need to know the following questions before diagnosing the issue with your string trimmer.

  1. Which model string trimmer are you using?
  2. How old is your string trimmer?
  3. Which battery size did you use with your string trimmer?
  4. Was your battery fully charged before using your string trimmer?
I bought my EGO 15" trimmer early 2016 and have had "great success" thus far.  Therefore, I would recommend you review the Troubleshooting section below and see if any of these suggestions will work for you.  If not, then I would recommend you contact CS to help you resolve this issue - good luck!

Model: ST1500 Troubleshooting


(Edited)
Photo of Amber F.

Amber F., Official EGO Rep

  • 68,016 Points 50k badge 2x thumb
Scott, that is most certainly not how our trimmers are supposed to perform! Please call customer service: 1-855-EGO-5656 (1-855-346-5656).

This conversation is no longer open for comments or replies.