Lawnmower and battery problems

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Duplicate

1. Rail clamps do not stay in when rails extended. I have to wrap tape around them to hold out.
2. "full" battery does not last; indicator starts flashing red and sometimes it mowed half hour or more before really being depleted; or indicator turns red, but when battery placed on charger it shows 100%; or the battery wont charge; and now it has fully stopped charging, with the "25%" flashing a dull red. USELESS!
Photo of Trevor

Trevor

  • 120 Points 100 badge 2x thumb
  • Very frustrated with this machine. Its been an ongoing issue.

Posted 4 years ago

  • 1
Photo of Blue Angel

Blue Angel, Champion

  • 178,374 Points 100k badge 2x thumb
Official Response
1. Ego has a newer design of clamp that fixes that issue. Send them an email at support@egopowerplus.com


2. You may have a defective battery or charger. Include that info in your email and they will get you set up.
(Edited)
Photo of Denise C

Denise C

  • 6,334 Points 5k badge 2x thumb
Official Response
Hi Trevor! Thank you for your post and I'm sorry to hear that you are having issues with your handle locking clamps, as well as your battery and/or charger. I just responded to your private email that you sent us letting you know we would like to assist you with these issues directly, but we do not have your phone number to call you back. Please either give our customer support center a call
at (855) 346-5656, and have the serial numbers for your products
ready when calling; -or- reply to the email I just sent you with a good contact
number and I will call you back today.