I need help with a service repair

  • 1
  • Problem
  • Updated 5 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: out of date

I sent my lawn mower that I purchased in April 2014 to a service repair center in December of 2014 because it would not turn on. It is now May of 2015 and I can not get a word on when or if my mower can or will be fixed. In the meantime my lawn is growing out of control.
Photo of Shonda Miller

Shonda Miller

  • 244 Points 100 badge 2x thumb
  • frustrated

Posted 5 years ago

  • 1
Photo of Dominic49

Dominic49

  • 2,676 Points 2k badge 2x thumb
Have you called them and asked for an update?
Photo of SCDC

SCDC, Champion

  • 54,658 Points 50k badge 2x thumb
The forums are great to read and get generalized help, but to get the answer you need will require calling them.  Not to worry, they are a stress free call center  :)
Photo of Shonda Miller

Shonda Miller

  • 244 Points 100 badge 2x thumb
Thanks guys I will call them
Photo of SCDC

SCDC, Champion

  • 54,658 Points 50k badge 2x thumb
Ok, I can't resist.  Can you share what your issue was with the mower?  It's kind of interesting to know what the problem was and what it took to get it fixed.  I think it helps all of us.
Photo of Shonda Miller

Shonda Miller

  • 244 Points 100 badge 2x thumb
My mower worked just fine for me from April until October. In October it would not start up. I could hear the click but no power. So because it was under warranty i called EGO customer service they told me exactly where to take it too get it fixed. I did just that and Now it is May and no mower. 
Photo of Shonda Miller

Shonda Miller

  • 244 Points 100 badge 2x thumb
Now I am on the phone with customer service who just informed me that my information will be given to a supervisor and I should hear from them by next week...This is CRAZY.
Photo of SCDC

SCDC, Champion

  • 54,658 Points 50k badge 2x thumb
Keep us informed please.  Thank you very much for describing the issue you were having.
Photo of Shonda Miller

Shonda Miller

  • 244 Points 100 badge 2x thumb
Thank you I will 
Photo of Sandy

Sandy

  • 60 Points

My mower was working great until two days ago. I went to start it and only got a "click" sound, no lights, no action. It lit up when I pushed the LED button (headlights on a mower?), so I figured the battery is good. Customer Service had me extend the handle again, making sure I could see the arrows and the lines on the handle, as well as hearing it seat. It started right up. When it wouldn't start two days ago, I checked all the steps carefully, many times, including closing and extending the handle and making sure both sides were latched. Glad it was such an easy fix, even if it made me appear lame. Also, Customer Service had no record of my phone call or message I left for which they were supposed to call me back. A long "hold" time and two days later, I called them again and got right through and problem solved within 5 minutes. I do love the mower. I'm in Oklahoma and my son, in Seattle, has the same mower and loves his, as well.

Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 81,048 Points 50k badge 2x thumb
Sandy, we appreciate that you took the time to write in about your experience.  We appreciate the feedback and are working hard to improve our customer service experience to get it right the first time.  Thanks for your patience with us and welcome to the EGO family!
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 81,048 Points 50k badge 2x thumb
Official Response
Shonda, we are watching this case very carefully and will update you as we see progress.  This is most unfortunate and not up to our standards.  Rest assured that we will get you a resolution in a very timely manner.
Photo of Shonda Miller

Shonda Miller

  • 244 Points 100 badge 2x thumb
Thank you do much Jennifer. I appreciate it.
Photo of Shonda Miller

Shonda Miller

  • 244 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled VERY UPSET.

WITHOUT LAWN MOWER FOR 5 MONTHS. 
When I first got my Mower I was very very pleased, 6 months down the line it stopped working, no problem right? I have a 5yr Warranty so it would be a easy fix. Not true. My Mower has been sitting in the service center for 5 months. No problem during the winter months however it is MAY in NYC and my grass is in serious need of cutting. SO I had to go out and buy a new lawn mower to replace the 6 month old lawn mower I just purchased!!!! My wonderful $500.00 lawn mower has now cost me almost $1000.00. 
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 81,048 Points 50k badge 2x thumb
Shona, we are very surprised to hear this! Please know this is completely outside of our service guidelines and is unacceptable. A member of our EGO support team is going to reach out today and provide a direct solution.
Photo of Shonda Miller

Shonda Miller

  • 244 Points 100 badge 2x thumb
OK as of tonight My Problem has been fixed, Thank you Tracy @ Customer Service & her Supervisor My New Mower is On the way. 

This conversation is no longer open for comments or replies.