i just bought a new 56V battery

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: out of date

I just bought a new 56V battery, the old one was fried.  I did not register my lawnmower and Home Depot could not find my receipt, so I bought a new one.  I plugged it into my CH5500 rapid charger, which your manual says it works with and nothing happens.  I am used to the lights and charging sounds until it is fully charged  Does it charge the same way? If yes, what are my options, the recharger worked fine last week and now nothing.  What are my options?
Photo of Chris

Chris

  • 182 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Robert Waters

Robert Waters

  • 120 Points 100 badge 2x thumb
The same thing happened when I plugged in the replacement battery sent to me by the company, but its working in the mower. I'll use it until the battery is discharged and see if the charger works then. But evidently the battery arrived with a charge in it.
Photo of Chris

Chris

  • 182 Points 100 badge 2x thumb
Did you contact them to see if it my be the charger or the battery?
Photo of Robert Waters

Robert Waters

  • 120 Points 100 badge 2x thumb
No, because it worked in the mower. If it doesn't recharge, I'll look into whether the charger is no good.
Photo of Chris

Chris

  • 182 Points 100 badge 2x thumb
sounds reasonable thanks
Photo of Robert Waters

Robert Waters

  • 120 Points 100 badge 2x thumb
Please post how you make out with the issue.
Photo of Chris

Chris

  • 182 Points 100 badge 2x thumb
will do
Photo of Blue Angel

Blue Angel, Champion

  • 178,394 Points 100k badge 2x thumb
Chris, are you sure it was the battery malfunctioning and not the charger? It would seem an awful strange coincidence that the battery and charger would fail within a week of each other.
Photo of Chris

Chris

  • 182 Points 100 badge 2x thumb
I agree it seems a little coincidental, but I called the company help line and waited the 20 minutes.  They were very helpful, but they said the red light flashing was an indication that the battery was no longer good.  Which is why I purchased another.  

This conversation is no longer open for comments or replies.