I have a 20" mower. It cut for 15 or 20 minutes then just stopped.

  • 1
  • Problem
  • Updated 3 months ago
  • In Progress
  • (Edited)
I have a 20" mower.2 years old now. It cut for 15 or 20 minutes then just stopped. Battery is good, I have other ego product to test with. Did all of the trouble shooting. The lights on the mower are not lighting up?? Left it for 24 hours and still nothing. Any ideas?
Photo of Joyce Sgabellone

Joyce Sgabellone

  • 160 Points 100 badge 2x thumb

Posted 4 months ago

  • 1
Photo of William E Hanson

William E Hanson

  • 19,356 Points 10k badge 2x thumb
You're under warranty call customer service at 1-855-EGO-5656 (1-855-346-5656)
Photo of Joyce Sgabellone

Joyce Sgabellone

  • 160 Points 100 badge 2x thumb
Thanks, I did. was on hold 1/2 hour then left number for a call back. Finally the next day they called back but no one was on the line and then call went dead. It's a horrible process.
Photo of William E Hanson

William E Hanson

  • 19,356 Points 10k badge 2x thumb
Joyce, heard they're experiencing technical difficulties in customer service handling the influx of spring calls. Hang in there.
Photo of Joyce Sgabellone

Joyce Sgabellone

  • 160 Points 100 badge 2x thumb
Thanks, I'll try calling again when I get home from work.
Photo of Alex reed

Alex reed

  • 70 Points
Having the exact same problem, have you had this resolved yet?
Photo of Catherine Poole

Catherine Poole

  • 60 Points
my batteries are charged but the mower won't start, it goes green then yellow light flashes.  Don't know if I'm under warranty



Photo of Pam Bennett

Pam Bennett

  • 60 Points
Catherine, I am experiencing the same problem.  If you find out a solution, please post.
Photo of William E Hanson

William E Hanson

  • 19,356 Points 10k badge 2x thumb
Catherine, you have 5 years on the mower and 3 years on the battery, if you registered them. If not, you may still register if you have the receipt, model number and serial number. Customer service can help at 1-855-EGO-5656 (1-855-346-5656). Call early during the workday to avoid long waits.
Photo of Alex reed

Alex reed

  • 70 Points
With mine there is no lights etc. Its like the battery terminals aren't letting any power through. I have run a multimeter on the other side of the battery terminals and there is nothing.
Photo of Joyce Sgabellone

Joyce Sgabellone

  • 160 Points 100 badge 2x thumb
It took 4 weeks but I got my mower back and its working great again. My repair company was trying to get the wiring diagrams from customer service for weeks, finally they just order a new electric motor and circuit board under my warranty. Hoping I never have another problem. Had to pay a company to come cut my grass during the wait...that sure gets expensive.

Photo of szwoopp

szwoopp, Champion

  • 99,398 Points 50k badge 2x thumb
Good to hear you got your mower back and fully repaired Joyce.