HTA2000 Hedge Trimmer Attachment Not Locking Into Postion

  • 1
  • Problem
  • Updated 1 week ago
  • In Progress
I just bought the Hedge Trimmer Attachment to go along with my Power Head. The problem is that the Pin will not fit in the holes to lock the Trimmer into position. The head does spin freely but does not click into position. I am not sure if the pin is too large to fit into the holes or if the holes are misaligned.
Photo of michael vencill

michael vencill

  • 70 Points
  • Frustrated

Posted 1 week ago

  • 1
Photo of Oregon Mike

Oregon Mike, Champion

  • 52,004 Points 50k badge 2x thumb
If you bought it at Home Depot, you have 90 days to return/exchange it no questions asked. Even if you ordered it from HD online you can return it to a S&B HD store. 
Photo of Frank Woodbery

Frank Woodbery

  • 2,970 Points 2k badge 2x thumb
I doubt the there is a fit problem. Mine took some fidgeting to get the pin to align with the hole, but they eventually clicked securely into place without issue. Since this is only power head attachment tool I am using, I don't plan to separate them much.
Photo of Sunder

Sunder

  • 232 Points 100 badge 2x thumb
The alignment tape with the arrow sign may have been pasted wrong on the trimmer attachment. Try rotating it slightly in either direction to lock it into position.
Photo of summetj

summetj

  • 8,778 Points 5k badge 2x thumb
I always have problems getting that sucker to match up right.  Try wiggling it, pushing it in and out a few times, etc...it eventually does fit.
Photo of William E Hanson

William E Hanson

  • 10,192 Points 10k badge 2x thumb
I have several attachments including the extension pole and all fits and easily locks in place.