Hedge trimmer time delay to start (HT2400)

  • 2
  • Problem
  • Updated 1 year ago
  • Solved
I used my hedge trimmer maybe 3 times last year and when I went to use it today I thought it was failed.

Pushed the safety then the trigger and nothing. Did this a few times without success. Noted the battery light was green. Tried once more and it worked!

Ended up I forgot this tool has a couple second delay before it starts. My make a label and stick it on this tool as a reminder.

Why is there such a long delay time on this tool?

(FYI - this hedge trimmer outperforms my old gas trimmer by a long shot.)

Thanks

Mike
Photo of Michael G

Michael G

  • 8,810 Points 5k badge 2x thumb

Posted 1 year ago

  • 2
Photo of szwoopp

szwoopp, Champion

  • 106,500 Points 100k badge 2x thumb
Official Response
I believe the delay is just a safety feature.

It is a very good tool and I haven’t cut my extension cord once while using it. :)
(Edited)
Photo of Oregon Mike

Oregon Mike, Champion

  • 72,462 Points 50k badge 2x thumb
Agree with szwoopp, the delay is a safety feature. Love that hedge trimmer. I need more hedges!
Photo of Michael G

Michael G

  • 8,810 Points 5k badge 2x thumb
You don’t think it’s a little bit long of a delay? After all the tool already has a safety switch operation.
Photo of Oregon Mike

Oregon Mike, Champion

  • 72,462 Points 50k badge 2x thumb
Never really thought about the length of the delay. It is what it is. Once trimming, I've pretty much forgotten about the delay anyway. 
Photo of szwoopp

szwoopp, Champion

  • 106,500 Points 100k badge 2x thumb
At first, but got used to it pretty fast.