Hedge trimmer starts and stops after 2 seconds

  • 1
  • Problem
  • Updated 7 months ago
  • In Progress
  • (Edited)
Bought a hedge trimmer in spring and used it with no issues.  I went to trim the hedges in fall and it runs for 2 seconds and stops.  I tried multiple batteries and made 100% sure the batteries were charged.  No matter what I do the trimmer runs for 2 seconds and stops.  I do not see any obstructions and no guards were removed.
Photo of Kraig Repp

Kraig Repp

  • 80 Points 75 badge 2x thumb

Posted 7 months ago

  • 1
Photo of (a)Typical Engineer

(a)Typical Engineer

  • 25,758 Points 20k badge 2x thumb
Official Response
Sounds like the tool could be detecting a high load and is stopping for safety reasons.

What sort of plants did you cut in the Spring, and did they contain a lot of sap?  When you stored the tool after use, did you lubricate it before storage? Have you performed the maintenance procedure to clean and lubricate the blade as described in the manual?
CLEANING
WARNING: To avoid serious personal injury, always remove the battery pack
from the product when cleaning or performing any maintenance.
  • Use a soft brush to remove debris from all air intakes and cutting blade.
  • To remove pitch and other sticky residue, spray the blades with resin solvent.  Run the motor briefly so that the solvent is event distributed.
  • Wipe the surface with a dry cloth.
If everything appears normal and it still doesn't run, then you'll need to obtain warranty service:
HOW TO OBTAIN SERVICE
For warranty service, please contact EGO customer service toll-free at
1-855-EGO-5656. When requesting warranty service, you must present
the original dated sales receipt. An authorized service center will be selected
to repair the product according to the stated warranty terms.