Good mower, could not get the blade off for sharpening and charger shows 25% after charging now instead of 100%.

  • 1
  • Problem
  • Updated 5 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: duplicate

Bought an "EGO 20 in. 56-Volt Lithium-ion 3-in-1 Cordless Lawn Mower" back in April. Have been very pleased with it as it easily mows my 3/4 acre in two charges. What is great is that one can flip it over clean it out without an oily mess.

However I noticed that my blade was dinged so I was going to remove it. The bolt holding it was torqued too tight, the hole where the screw driver was to be placed was starting to give from the pressure - I filed the dings down while it was still attached.

The next thing that happened was with the charger, as soon as the battery was charged it displayed the 25% light, not the usual green 100% - the battery showed green and functioned fine.

I like the product, however I would like to be able to replace the blade when it gets more "use" and the charger issue is a new one.
Photo of Scott Middleton

Scott Middleton

  • 200 Points 100 badge 2x thumb

Posted 5 years ago

  • 1
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 80,888 Points 50k badge 2x thumb
Official Response
Hi Scott,  It sounds like you have a problem that we can solve.  Give us a call at 1-855-346-5656 at your convenience and we'd be happy to troubleshoot your blade and charger issue.  You are covered by our 5 year warranty for your mower so you have nothing to worry about.