Flashing red light rapid charger problems

  • 1
  • Problem
  • Updated 8 months ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Duplicate

Rapid charger goes through usual startup sequence with flashing lights and fan at couple of speeds then goes to a third lower stage fan blower speed and get flashing red light in first left light position on charger and fan goes off.  Maintains this status for about 5 - 10 minutes and then goes through same startup sequence again as above with same result.  No chagrining occurs.  Have tried with various EGO batteries and get same result unless fully charged and then get all four charger lights on and turns fan off and does not charge.  I was able to charge all the batteries above on the standard charger.

Seems as though this is a charger problem and not a battery problem as the flashing red light suggests.  Thoughts?

Photo of John Kohne

John Kohne

  • 134 Points 100 badge 2x thumb

Posted 8 months ago

  • 1
Photo of Jacob

Jacob, Champion

  • 61,376 Points 50k badge 2x thumb
Official Response
Multiple batteries would definitely confirm your suspicions.

If it's under warranty. Call ego. They will replace it