EGOPOWER LB5750

  • 1
  • Problem
  • Updated 1 month ago
My battery powered Leaf blower is shorting out after I run it for about a minute. When I release the trigger and reactivate it runs for a little while longer than shorts out again. This continues until the battery is worn down. Does anyone else have this issue?
Photo of David Matheson

David Matheson

  • 70 Points

Posted 1 month ago

  • 1
Photo of Oregon Mike

Oregon Mike, Champion

  • 44,900 Points 20k badge 2x thumb
Are you using it to blow snow? If so, that's been a common reported problem here on the forum. It seems the snow can get sucked into the back of the blower causing some shorting type problems. 
Does it seem to do it at any speed setting? Or only full blast? Or...
Photo of William E Hanson

William E Hanson

  • 5,920 Points 5k badge 2x thumb
Before I bought the EGO Snowblower,I did use my leaf blower several times, but didn't have this problem. Maybe because I waited for it to stop snowing before blowing.
Photo of Oregon Mike

Oregon Mike, Champion

  • 44,900 Points 20k badge 2x thumb
Seems it did happen even if it wasn't actively snowing. I guess the snow gets blown up in the air enough to find its way into the leaf blower. Sounds like you have good technique and/or were lucky. Hopefully OP will return and give a bit more detail about usage.
Photo of William E Hanson

William E Hanson

  • 5,920 Points 5k badge 2x thumb
Blow with the wind, not against or you'll get it in the face as well as sucking into the intake.